Bug 201497 - base modul drops forms and report wizard is messed up
base modul drops forms and report wizard is messed up
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-06 08:22 EDT by Alfons Zitterbacke
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 08:19:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alfons Zitterbacke 2006-08-06 08:22:04 EDT
Description of problem:


Version-Release number of selected component (if applicable): 2.0.2-5.17.2.2


How reproducible:
create an OpenOffice Database Document with an other 2.0.2 OpenOffice Base and
create some forms within it. After reopening with the current OpenOffice.Org
Base from openoffice.org-2.0.2-5.17.2.src.rpm, the forms are missing (the
contents.xml in the root of the odb archive got corrupted or at least does not
list the forms). Then use the report wizard to create a report form a query.
Select some or all availabe fields (#>1), and in the grouping part, it will list
some fields twice or not list the ones selected before, looking quite randomly.


Steps to Reproduce:
1. create OpenOffice Base document with tables and queries 
2. start report wizard
3. go to the select-fields-to-group-by part 
  
Actual results:
find the field list messed up

Expected results:
the same fields as specified in the query and selected before 

Additional info:
this happened to me after my document got corrupted (I don't know why) so that
the forms were not listed anymore. They were not dropped from the file but no
longer listed in the contents.xml in the root of the zip-encoded odb file.
Comment 1 Alfons Zitterbacke 2006-08-06 08:22:50 EDT
Here comes the rpm query information:
bash-3.1$ rpm -q openoffice.org-base --info
Name        : openoffice.org-base          Relocations: (not relocatable)
Version     : 2.0.2                             Vendor: Red Hat, Inc.
Release     : 5.17.2                        Build Date: Sa 15 Jul 2006 01:31:42 CEST
Install Date: Sa 05 Aug 2006 14:00:21 CEST      Build Host:
hs20-bc2-4.build.redhat.com
Group       : Development/Libraries         Source RPM:
openoffice.org-2.0.2-5.17.2.src.rpm
Size        : 2198640                          License: LGPL
Signature   : DSA/SHA1, Mo 31 Jul 2006 21:26:58 CEST, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.openoffice.org/
Summary     : Datenbank-Frontend für OpenOffice.org
Description :
Gui database frontend for openoffice.org. Allows creation and management of
databases
through a GUI.
Comment 2 Alfons Zitterbacke 2006-08-06 08:24:51 EDT
Here comes the output of openoffice to the console

bash-3.1$ openoffice.org-2.0 Datenbank\ 1.odb
com.sun.star.container.NoSuchElementException:
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy46.getByName(Unknown Source)
        at
com.sun.star.wizards.report.ReportDocument.setLayoutSectionsVisible(ReportDocument.java)
        at
com.sun.star.wizards.report.Dataimport.addTextSectionCopies(Dataimport.java)
        at
com.sun.star.wizards.report.Dataimport.insertDatabaseDatatoReportDocument(Dataimport.java)
        at com.sun.star.wizards.report.Dataimport.importReportData(Dataimport.java)
        at com.sun.star.wizards.report.Dataimport.createReport(Dataimport.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
java.lang.NullPointerException
        at com.sun.star.wizards.report.DBColumn.<init>(DBColumn.java)
        at
com.sun.star.wizards.report.ReportDocument.getallDBColumns(ReportDocument.java)
        at
com.sun.star.wizards.report.Dataimport.insertDatabaseDatatoReportDocument(Dataimport.java)
        at com.sun.star.wizards.report.Dataimport.importReportData(Dataimport.java)
        at com.sun.star.wizards.report.Dataimport.createReport(Dataimport.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
com.sun.star.container.NoSuchElementException:
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy46.getByName(Unknown Source)
        at
com.sun.star.wizards.report.ReportDocument.setLayoutSectionsVisible(ReportDocument.java)
        at
com.sun.star.wizards.report.Dataimport.insertDatabaseDatatoReportDocument(Dataimport.java)
        at com.sun.star.wizards.report.Dataimport.importReportData(Dataimport.java)
        at com.sun.star.wizards.report.Dataimport.createReport(Dataimport.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
java.lang.IllegalArgumentException: No such control !
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at com.sun.star.wizards.ui.ControlScroller.initialize(ControlScroller.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoNextAvailableStep(WizardDialog.java)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
=======================================================
=== Note: An Exception was thrown which should have ===
=== caused a crash. I caught it. Please report this ===
=== to  openoffice.org                              ===
=======================================================
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
Caused by: java.lang.NullPointerException
        at com.sun.star.wizards.ui.UnoDialog.getpreferredLabelSize(UnoDialog.java)
        at
com.sun.star.wizards.ui.TitlesComponent.adjustPosSizes(TitlesComponent.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoNextAvailableStep(WizardDialog.java)
        ... 13 more
java.lang.IllegalArgumentException: No such control !
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at
com.sun.star.wizards.ui.ControlScroller.scrollControls(ControlScroller.java)
        at
com.sun.star.wizards.ui.ControlScroller$AdjustmentListenerImpl.adjustmentValueChanged(ControlScroller.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
java.lang.IllegalArgumentException: No such control !
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at com.sun.star.wizards.ui.ControlScroller.initialize(ControlScroller.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoPreviousAvailableStep(WizardDialog.java)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
=======================================================
=== Note: An Exception was thrown which should have ===
=== caused a crash. I caught it. Please report this ===
=== to  openoffice.org                              ===
=======================================================
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
Caused by: java.lang.NullPointerException
        at com.sun.star.wizards.ui.UnoDialog.getpreferredLabelSize(UnoDialog.java)
        at
com.sun.star.wizards.ui.TitlesComponent.adjustPosSizes(TitlesComponent.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoPreviousAvailableStep(WizardDialog.java)
        ... 13 more
java.lang.IllegalArgumentException: No such control !
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at com.sun.star.wizards.ui.ControlScroller.initialize(ControlScroller.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoNextAvailableStep(WizardDialog.java)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
=======================================================
=== Note: An Exception was thrown which should have ===
=== caused a crash. I caught it. Please report this ===
=== to  openoffice.org                              ===
=======================================================
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
Caused by: java.lang.NullPointerException
        at com.sun.star.wizards.ui.UnoDialog.getpreferredLabelSize(UnoDialog.java)
        at
com.sun.star.wizards.ui.TitlesComponent.adjustPosSizes(TitlesComponent.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoNextAvailableStep(WizardDialog.java)
        ... 13 more
java.lang.IllegalArgumentException: No such control !
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at com.sun.star.wizards.ui.ControlScroller.initialize(ControlScroller.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoPreviousAvailableStep(WizardDialog.java)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
=======================================================
=== Note: An Exception was thrown which should have ===
=== caused a crash. I caught it. Please report this ===
=== to  openoffice.org                              ===
=======================================================
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
Caused by: java.lang.NullPointerException
        at com.sun.star.wizards.ui.UnoDialog.getpreferredLabelSize(UnoDialog.java)
        at
com.sun.star.wizards.ui.TitlesComponent.adjustPosSizes(TitlesComponent.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoPreviousAvailableStep(WizardDialog.java)
        ... 13 more
java.lang.IllegalArgumentException: No such control !
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at com.sun.star.wizards.ui.ControlScroller.initialize(ControlScroller.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoNextAvailableStep(WizardDialog.java)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
=======================================================
=== Note: An Exception was thrown which should have ===
=== caused a crash. I caught it. Please report this ===
=== to  openoffice.org                              ===
=======================================================
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
Caused by: java.lang.NullPointerException
        at com.sun.star.wizards.ui.UnoDialog.getpreferredLabelSize(UnoDialog.java)
        at
com.sun.star.wizards.ui.TitlesComponent.adjustPosSizes(TitlesComponent.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoNextAvailableStep(WizardDialog.java)
        ... 13 more
java.lang.IllegalArgumentException: No such control !
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at com.sun.star.wizards.ui.ControlScroller.initialize(ControlScroller.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoPreviousAvailableStep(WizardDialog.java)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
=======================================================
=== Note: An Exception was thrown which should have ===
=== caused a crash. I caught it. Please report this ===
=== to  openoffice.org                              ===
=======================================================
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
Caused by: java.lang.NullPointerException
        at com.sun.star.wizards.ui.UnoDialog.getpreferredLabelSize(UnoDialog.java)
        at
com.sun.star.wizards.ui.TitlesComponent.adjustPosSizes(TitlesComponent.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoPreviousAvailableStep(WizardDialog.java)
        ... 13 more
java.lang.IllegalArgumentException: No such control !
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at com.sun.star.wizards.ui.ControlScroller.initialize(ControlScroller.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoNextAvailableStep(WizardDialog.java)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
=======================================================
=== Note: An Exception was thrown which should have ===
=== caused a crash. I caught it. Please report this ===
=== to  openoffice.org                              ===
=======================================================
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
Caused by: java.lang.NullPointerException
        at com.sun.star.wizards.ui.UnoDialog.getpreferredLabelSize(UnoDialog.java)
        at
com.sun.star.wizards.ui.TitlesComponent.adjustPosSizes(TitlesComponent.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoNextAvailableStep(WizardDialog.java)
        ... 13 more
java.lang.IllegalArgumentException: No such control !
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at
com.sun.star.wizards.ui.ControlScroller.fillupControls(ControlScroller.java)
        at com.sun.star.wizards.ui.ControlScroller.initialize(ControlScroller.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoPreviousAvailableStep(WizardDialog.java)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
=======================================================
=== Note: An Exception was thrown which should have ===
=== caused a crash. I caught it. Please report this ===
=== to  openoffice.org                              ===
=======================================================
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
com.sun.star.wizards.ui.event.MethodInvocation.invoke(MethodInvocation.java)
        at
com.sun.star.wizards.ui.event.AbstractListener.invoke(AbstractListener.java)
        at
com.sun.star.wizards.ui.event.CommonListener.actionPerformed(CommonListener.java)
        at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
        at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java)
        at $Proxy100.execute(Unknown Source)
        at com.sun.star.wizards.ui.UnoDialog.executeDialog(UnoDialog.java)
        at
com.sun.star.wizards.report.ReportWizard.startReportWizard(ReportWizard.java)
        at
com.sun.star.wizards.report.CallReportWizard$ReportWizardImplementation.trigger(CallReportWizard.java)
Caused by: java.lang.NullPointerException
        at com.sun.star.wizards.ui.UnoDialog.getpreferredLabelSize(UnoDialog.java)
        at
com.sun.star.wizards.ui.TitlesComponent.adjustPosSizes(TitlesComponent.java)
        at com.sun.star.wizards.ui.TitlesComponent.initialize(TitlesComponent.java)
        at com.sun.star.wizards.report.ReportWizard.enterStep(ReportWizard.java)
        at com.sun.star.wizards.ui.WizardDialog.switchToStep(WizardDialog.java)
        at
com.sun.star.wizards.ui.WizardDialog.gotoPreviousAvailableStep(WizardDialog.java)
        ... 13 more

See, I created the document about a month ago and have sun java 1.5 installed.
That time, it worked fine and the only thing I changed this that time is that I
installed all fedora updates available with yum.
Comment 3 Caolan McNamara 2006-08-07 09:12:45 EDT
possibly some libgcj thing, or maybe some cock-up all of my own
Comment 4 Caolan McNamara 2006-08-09 05:03:42 EDT
Can you attach the offending document, I can't reproduce a problem from scratch.
I want to verify that the document is not actually corrupt itself, i.e. that
it's a problem with OOo, and not with something that has occured outside OOo
with the document.
Comment 5 Alfons Zitterbacke 2006-08-22 11:25:17 EDT
Hm. I don't have the original document available now.
I removed the fedora distributed openoffice version and installed the
openoffice.org 2.0.3 from de.openoffice.org. Now it is working fine, after I
fixed the contents.xml to list the forms. I found that there are a I/O errors
listet in openoffice bug reports and one of them applied to me, esp. regarding
some error messages about script-lb.xml. 

I'm sorry that I couldn't reply earlier but my mail account was messed up.

Note You need to log in before you can comment on or make changes to this bug.