Bug 20151 - error occurs when doing kick start with cdrom (ks.cfg is on the cdrom itself)
error occurs when doing kick start with cdrom (ks.cfg is on the cdrom itself)
Status: CLOSED DUPLICATE of bug 22285
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-01 11:44 EST by Chi-To Shiu
Modified: 2007-04-18 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 05:18:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chi-To Shiu 2000-11-01 11:44:38 EST
Using the Red Hat CD as a base, I am trying to build a CD that will boot and call kick start to install linux on a pc automatically.  
I approached  it by modfying syslinux.cfg in boot.img, and adding a ks.cfg to the cdrom.   
It got quite far, in fact I thought it installed all the RPM I wanted before it ran into the problem.  
It is an anaconda related problem, and here is the anacdump file:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in __call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1756, in doInstall
    self.method.writeCleanupPath(f)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 112, in writeCleanupPath
    isys.makeDevInode(self.device, "/tmp/cdrom")
  File "/usr/lib/anaconda/isys.py", line 195, in makeDevInode
    return _isys.mkdevinode(name, fn)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fn: /tmp/cdrom
name: unknown

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/source/.'
sS'device'
p8
S'unknown'
p9
sS'progressWindow'
p10

<failed>
Comment 1 Michael Fulbright 2000-11-03 15:11:25 EST
Seems related to bug  18403 possibly.

Comment 2 Michael Fulbright 2000-11-03 15:11:52 EST
Passed to QA to reproduce.
Comment 3 Brock Organ 2000-11-15 09:20:10 EST
could you attach the kickstart file you used ...?
Comment 4 Chi-To Shiu 2000-11-15 16:48:00 EST
The following is the ks script I have used.

#########################################################
#
# Kickstart commands section
#
auth

# Be very! very! careful with this!!!

lang en_US
keyboard us
mouse

network --bootproto static --ip 15.23.56.28 --gateway 15.23.56.1 --nameserver 
15.23.62.6 --netmask 255.255.255.0
cdrom

zerombr yes
clearpart --all
part /boot --size 20
part swap --size 128
part / --size 1024 
part /var --size 1024
part /home --size 500
part /home/dazel/var --size 500 --grow
install
reboot

lilo
rootpw genesis
timezone America/Chicago

#########################################################
#
# Packages
#

%packages
@ Dazel Server

#########################################################
#
# Post installation, currently nothing
#

%post
# add comment to /etc/motd
echo "HP Document Router installed `/bin/date`" > /etc/motd

# add the dazel user
adduser dazel

# small router, so install the small ServerList file
cp /home/dazel/etc/ServerList.small /home/dazel/etc/ServerList

Comment 5 Need Real Name 2000-11-15 17:34:31 EST
The failure appears to be happening because self.device is not specified 
properly when the Python CdromInstallMethod object. Anaconda gets this from the 
method command line argument, so I can hazard a guess that anaconda is not 
being invoked properly in this case. Perhaps the problem is in anaconda-
runtime/loader/loader-local or loader-local-kon?
Comment 6 Need Real Name 2000-11-17 18:06:59 EST
I was able to work around the problem for now by 
changing /usr/lib/anaconda/image.py line 112 to hard code the cdrom device ID. 
i.e.:

isys.mkDevInode(self.device,"/tmp/cdrom") was changed to
isys.mkDevInode("hda","/tmp/cdrom") 

This works, but it fails to explain why loader-local is unable to properly 
determine the cdrom identity automatically (It is still invoking anaconda with
an install method argument of "cdrom://unknown/mnt/source" while it should be
using "cdrom://hda/mnt/source").
Comment 7 Michael Fulbright 2001-02-15 11:59:27 EST
What kind of CDROM do you have? The output from /proc/ide/hda/model would be a
good start, as well as /proc/ide/hda/media.
Comment 8 Chi-To Shiu 2001-02-15 12:22:36 EST
content in the media file is "cdrom"
content in the model file is "CD-224E"
Comment 9 Michael Fulbright 2001-04-11 12:01:17 EDT
On VC3 it should print out something during the loader like:

* trying to mount device <device>

what does this report on your system?
Comment 10 Michael Fulbright 2001-04-11 12:08:16 EDT
This bug looks related to bug 22302.
Comment 11 Michael Fulbright 2001-04-11 12:09:47 EDT
Correct that, bug 22285.
Comment 12 Need Real Name 2001-04-16 11:02:14 EDT
It is possible that bug 20151 and 22285 are related, however there is an 
important difference.  22285 deals with not being able to find the kickstart 
file at all.  In this bug (20151), the kickstart file is found and installation 
is proceeding normally until the post install phase where it dies because it is 
unable to clean up after itself.

To answer the question that you had, the partial output on my <VC3> is:

* trying to mount device hdb
* loopfd is 6
* kickstarting through device hdb
* trying to mount device hdb
* found url image cdrom://unknown/mnt/source/.

That is all I got before it disappeared off the screen.
Comment 13 Pekka Savola 2001-04-23 05:18:33 EDT
I was bitten by this exact same problem too; after %post, the anaconda installer
dies with the exactly same traceback.

My cdrom is /dev/hdd. Model is '685A' and media 'cdrom'.  I get the same unknown
message
at boot.

The cdrom install works if I load kickstart from the floppy.
Comment 14 Michael Fulbright 2001-06-27 13:58:53 EDT

*** This bug has been marked as a duplicate of 22285 ***

Note You need to log in before you can comment on or make changes to this bug.