Bug 201522 - User cannot run Wireshark in unprivileged mode
Summary: User cannot run Wireshark in unprivileged mode
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: usermode   
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
: ---
Assignee: Miloslav Trmač
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-07 03:35 UTC by Matt Seitz
Modified: 2008-07-24 20:16 UTC (History)
4 users (show)

Fixed In Version: RHBA-2008-0687
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 19:36:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB backtrace (530 bytes, text/plain)
2007-03-16 17:42 UTC, Matt Seitz
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0687 normal SHIPPED_LIVE usermode bug fix update 2008-07-23 15:57:07 UTC

Description Matt Seitz 2006-08-07 03:35:55 UTC
+++ This bug was initially created as a clone of Bug #159958 +++


Description of problem:
Attempting to open ethereal as an unprivilged user:

$ ethereal

Warning window opens asking for root password.  When clicking on the
'unprivilged' button, program exits with 'Unknown Error' window and a close button.

Version-Release number of selected component (if applicable):
usermode-1.74-1
ethereal-gnome-0.99.0-EL4.2

How reproducible:
Always

Steps to Reproduce:
1. Open Ethereal as non-root user.
2. Select 'Unpriviliged' button
3. Program exits with 'Unknown Error'.
  

Actual Results:  Program exits with a '0' result code.

Expected Results:  Program opens with non-privilged user permissions, allowing a
user to do an ethereal analysis of a packet capture owned by the user.

Additional info:

Comment 1 Matt Seitz 2006-08-07 03:38:18 UTC
Workaround:  run "/usr/sbin/ethereal" directly, bypassing "consolehelper".

Comment 2 Miloslav Trmač 2007-03-16 05:16:30 UTC
Thanks for your report.

I can't reproduce the crash on i386.  Please:
* run wireshark,
* when the password dialog appears, switch to a virtual terminal
* attach gdb to the "userhelper" process and let it continue.
* switch to X, select the "Unprivileged" button
* switch back to a virtual terminal; if gdb reports a crash,
  please generate a backtrace and attach it to this bug report.

Comment 3 Matt Seitz 2007-03-16 17:42:54 UTC
Created attachment 150262 [details]
GDB backtrace

GDB reported a sigsegv.  I'm attaching the backtrace.

Comment 4 Miloslav Trmač 2007-03-18 06:15:19 UTC
Thank you, this indeed seems to be a the same bug as #159958.

Comment 5 RHEL Product and Program Management 2007-11-29 04:25:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 9 errata-xmlrpc 2008-07-24 19:36:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0687.html

Comment 10 Matt Seitz 2008-07-24 20:16:12 UTC
Thank you for fixing this.


Note You need to log in before you can comment on or make changes to this bug.