Bug 20155 - server only accepts pasv connects
Summary: server only accepts pasv connects
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-01 19:12 UTC by o.schnapauff
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-01 19:12:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description o.schnapauff 2000-11-01 19:12:14 UTC
Always get cannot build data connection: connection refused
when ftping to the alpha server (after login, when trying
to do ls or download).

switching to pas (passive) works. client is win 98 or linux x86, same
effect. Server doesnt seem to correctly open the port.

no firewall in place. direct connection, used to work before upgrade.

Comment 1 Bernhard Rosenkraenzer 2000-11-02 11:35:33 UTC
I can't reproduce this (works here, server == AlphaServer DS20, client == Linux x86).
By any chance, did you recompile wu-ftpd with --disable-port?

Comment 2 Bernhard Rosenkraenzer 2000-11-02 11:36:53 UTC
Another option is that your clients are broken. Check if recompiling wu-ftpd with --enable-badclients fixes the problem for you. (If it does, check wu-ftpd's CHANGES file for the details and update your clients).


Comment 3 Need Real Name 2001-05-24 16:47:34 UTC
I have the same problem, but from redhat 7.0 clients it says that the connection
if refused.


Note You need to log in before you can comment on or make changes to this bug.