Bug 201587 - 'Enable Desktop Effects' makes system unusable
'Enable Desktop Effects' makes system unusable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 12:48 EDT by David Aquilina
Modified: 2014-06-23 20:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: FC6Test3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 17:13:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.95 KB, application/octet-stream)
2006-08-07 12:48 EDT, David Aquilina
no flags Details

  None (edit)
Description David Aquilina 2006-08-07 12:48:15 EDT
Description of problem:
When enabling Desktop Effects (via the desktop-effects app), the window manager
disappears. The gnome panels and nautilus continue to run. 

If you attempt to disable desktop affects (or click on the 'Use previous
settings' button on the confirmation dialog), the entire system locks hard - it
is not responsive to the keyboard or even remotely over the network. In order to
recover, you must restart the system, boot into the failsafe session, and run
the desktop-effects app from there to disable it. 


Version-Release number of selected component (if applicable):
compiz-0.0.13-0.14.20060721git.fc5.aiglx
xorg-x11-server-Xorg-1.1.1-15.fc6
xorg-x11-drv-ati-6.6.1-7.fc6


How reproducible:
Always

Steps to Reproduce:
1. Login to GNOME Session
2. run 'desktop-effects', click 'Enable Desktop Effects'
3. (optionally) click on 'Use previous settings'
  
Actual results:
Unusable system 

Expected results:
Pretty eyecandy

Additional info:

The system is an IBM ThinkPad T42. It is mostly rawhide from August 4th, with
select components (kernel, compiz, X server, gnome-menus) from today's (August
7th) rawhide. 

# uname -a
Linux cthulhu 2.6.17-1.2528.fc6 #1 SMP Sun Aug 6 01:43:42 EDT 2006 i686 i686
i386 GNU/Linux
# lspci | grep -i vga
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW
[Radeon Mobility 7500]
Comment 1 David Aquilina 2006-08-07 12:48:15 EDT
Created attachment 133748 [details]
xorg.conf
Comment 2 Gary Case 2006-08-10 17:58:55 EDT
I'm trying this out on an Intel devel box with the i915 driver and it fails in a
different way with the 10-Aug-2006 Rawhide. When you click "Enable Desktop
Effects", the panels and the title bar of all open windows disappear. I am able
to get everything back to normal by clicking the "Use Previous Settings" button.
Comment 3 Kristian Høgsberg 2006-08-23 13:47:49 EDT
There's two different bugs here: the lockup with the T42 should be fixed in
rawhide now (or at least tomorrow, make sure you have at least
mesa-libGL-6.5-23.20060818cvs.fc6).  Please try that out.

As for the problem with the intel box, I suspect that is a dupe of bugs #203284.
 Please try the work around described there, and if that doesn't work, open a
new bugs, attach the output of

  gconftool-2 --dump /apps/compiz

The preferred way of starting compiz is to enable it from the "Desktop Effects"
disalog in System->Preferences->More Preferences.  If you're starting compiz
manually (not recommended), make sure that gnome-window-decorator has been
started on the same display before running compiz.
Comment 4 David Aquilina 2006-09-27 17:13:19 EDT
Doing a clean install of FC6Test3 fixes the problem. 

Note You need to log in before you can comment on or make changes to this bug.