Bug 20169 - linux-2.2.16-22 not compiling with CONFIG_IP_MASQUERADE=y
Summary: linux-2.2.16-22 not compiling with CONFIG_IP_MASQUERADE=y
Status: CLOSED DUPLICATE of bug 19070
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL: http://darthracing.com
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-01 23:33 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-04 07:23:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My /usr/src/linux/.config file, in case its something stupid on my part.... (9.03 KB, text/plain)
2000-11-01 23:36 UTC, Need Real Name
no flags Details

Description Need Real Name 2000-11-01 23:33:17 UTC
I tried compiling the shipped kernel with 
CONFIG_IP_MASQUERADE=y
and I get the crash below.

Without the CONFIG_IP_MASQUERADE=y, the kernel compiles fine.
bzImage/bzlilo/zImage all fail, as do combinations of selecting ICMP
masquing
(other fields seemed to make no difference). My modules still compile.

Thanks
Todd

.
.
make[2]: Leaving directory `/usr/src/linux/net/802'
make -C ipv4
make[2]: Entering directory `/usr/src/linux/net/ipv4'
make all_targets
make[3]: Entering directory `/usr/src/linux/net/ipv4'
kgcc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2
-fomit-
frame-pointer -fno-strict-aliasing -pipe -fno-strength-reduce -m486
-malign-loop
s=2 -malign-jumps=2 -malign-functions=2 -DCPU=586   -DEXPORT_SYMTAB -c
ip_masq.c
ip_masq.c:578: `ip_masq_hash' undeclared here (not in a function)
ip_masq.c:578: initializer element for `__ksymtab_ip_masq_hash.value' is
not con
stant
ip_masq.c:579: `ip_masq_unhash' undeclared here (not in a function)
ip_masq.c:579: initializer element for `__ksymtab_ip_masq_unhash.value' is
not c
onstant
ip_masq.c:518: warning: `masq_port_lock' defined but not used
make[3]: *** [ip_masq.o] Error 1
make[3]: Leaving directory `/usr/src/linux/net/ipv4'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux/net/ipv4'
make[1]: *** [_subdir_ipv4] Error 2
make[1]: Leaving directory `/usr/src/linux/net'
make: *** [_dir_net] Error 2
[root@flipper linux]# grep MASQ .config
CONFIG_IP_MASQUERADE=y
# CONFIG_IP_MASQUERADE_ICMP is not set

Comment 1 Need Real Name 2000-11-01 23:36:27 UTC
Created attachment 4894 [details]
My /usr/src/linux/.config file, in case its something stupid on my part....

Comment 2 Bill Nottingham 2000-11-04 07:23:33 UTC
Did you run 'make mrproper' first?

Comment 3 Bill Nottingham 2000-11-04 07:46:48 UTC

*** This bug has been marked as a duplicate of 19070 ***


Note You need to log in before you can comment on or make changes to this bug.