Bug 201709 - unable to display created PVs with pvs or pvscan
unable to display created PVs with pvs or pvscan
Status: CLOSED DUPLICATE of bug 195276
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-08 09:55 EDT by Mike Snitzer
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 10:01:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Snitzer 2006-08-08 09:55:09 EDT
Description of problem:
unable to display created PVs with pvs or pvscan (with and without having
write_cache_state enabled)

Version-Release number of selected component (if applicable):
lvm2-2.02.06-3.0.RHEL4

How reproducible:
Always

Steps to Reproduce:
1. create N physical volumes
2. try to list the created PVs with pvs or pvscan
3. no pvs are listed, -vvvv output shows devices being "orphaned"
  
Actual results:
pvs -vvvv 2>&1 shows:
#device/dev-io.c:437         Opened /dev/sdc RO
#device/dev-io.c:264       /dev/sdc: size is 35843670 sectors
#device/dev-io.c:134         /dev/sdc: block size is 1024 bytes
#device/dev-io.c:483         Closed /dev/sdc
#device/dev-io.c:264       /dev/sdc: size is 35843670 sectors
#device/dev-io.c:437         Opened /dev/sdc RO O_DIRECT
#device/dev-io.c:134         /dev/sdc: block size is 1024 bytes
#device/dev-io.c:483         Closed /dev/sdc
#filters/filter-composite.c:31         Using /dev/sdc
#device/dev-io.c:437         Opened /dev/sdc RO O_DIRECT
#device/dev-io.c:134         /dev/sdc: block size is 1024 bytes
#label/label.c:158       /dev/sdc: lvm2 label detected
#cache/lvmcache.c:651         lvmcache: /dev/sdc: now orphaned
#format_text/format-text.c:915         <backtrace>
#device/dev-io.c:483         Closed /dev/sdc

Expected results:
should list the pvs that were previosuly created
Comment 1 Alasdair Kergon 2006-08-08 10:01:50 EDT

*** This bug has been marked as a duplicate of 195276 ***

Note You need to log in before you can comment on or make changes to this bug.