Bug 201714 - Unable to read cifs share
Unable to read cifs share
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-08 10:28 EDT by Leonardo Pinto
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-23 15:01:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonardo Pinto 2006-08-08 10:28:08 EDT
Description of problem:
Unable to read files in cifs share, however writer enabled...

Version-Release number of selected component (if applicable):
Samba-3.0.23a-1.fc5.1;
However in the version 3.0.23-1.fc5 the problem does not happen.

How reproducible:
/bin/mount -t cifs -o iocharset=utf8,username=xxx,password=xxx //ip-server/share
/share
OR
//ip-server/share /share cifs
uid=501,gid=500,iocharset=utf8,username=xxx,password=xxx,rw,auto 0 0

Steps to Reproduce:
1. ls > /share/test
2. l /share/test
3. cat /share/test
  
Actual results:
No content is shown

Expected results:
The content of the file

Additional info:
After update Samba to version 3.0.23a-1.fc5.1,
*** however in the version 3.0.23-1.fc5 the problem does not happen ***

Server: 
Linux servidor.openlogic 2.6.17-1.2157_FC5xenU #1 SMP Wed Jul 12 00:46:43 EDT
2006 i686 i686 i386 GNU/Linux

Workstation:
Linux estacao001.openlogic 2.6.17-1.2157_FC5 #1 Tue Jul 11 22:55:46 EDT 2006
i686 i686 i386 GNU/Linux
Comment 1 Steve French 2006-11-25 15:51:36 EST
This seems like the access flags bug in Samba server introduced in Samba
3.0.23a, fixed in Samba 3.0.23b server and later.

This version of server is available for update, the defect could be returned
Comment 2 Simo Sorce 2007-03-26 11:16:43 EDT
we ship 3.0.24 now, can you please confirm this is fixed for you now?
thanks.
Comment 3 Simo Sorce 2007-11-23 15:01:48 EST
This works for me with recent packages.

Note You need to log in before you can comment on or make changes to this bug.