Bug 201715 - Problem importing excel file
Problem importing excel file
Status: CLOSED DUPLICATE of bug 201546
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-08 10:35 EDT by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 10:40:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File which causes the crash (84.00 KB, application/vnd.ms-excel)
2006-08-08 10:35 EDT, Paul F. Johnson
no flags Details

  None (edit)
Description Paul F. Johnson 2006-08-08 10:35:52 EDT
Description of problem:
I'm unable to import the attached xls file (it's never been near excel, but the
boss wants it sent that way)

Version-Release number of selected component (if applicable):
2.0.3-8

How reproducible:
Always

Steps to Reproduce:
1. Try and load the attached file
2.
3.
  
Actual results:
(I) x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/i810_drv.so
(III) Desktop is: GNOME
(IV) libgcj version is: libgcj-4.1.1-14-i386
(V) kernel is: Linux 2.6.17-1.2517.fc6 #1 SMP Thu Aug 3 05:00:47 EDT 2006 i686
i686 i386
(VI) OpenOffice.org core rpm version is:
openoffice.org-core-2.0.3-7.6-i386openoffice.org-core-2.0.3-7.7-i386openoffice.org-core-2.0.3-7.8-i386
(VII) accessibility is: false
(VIII) fedora release is: Fedora Core release 5.91 (FC6 Test2)
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          permissive
Policy version:                 20
Policy from config file:        targeted
...end sestatus details ...
0x17a3780: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e780
0x17a3fc0: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1efc0
0xb7f09420:  + 0x420 (__kernel_sigreturn + 0x0)
0x70fa57d: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x3c57d
0xfe4166: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x286166
0xfe6dd1: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x288dd1
0xfe7b42: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x289b42
0xfea328: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x28c328
0xfea646: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x28c646
0xfbb16a: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x25d16a
(EditEngine::SetUpdateMode(unsigned char) + 0x24)
0x99060d: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x35d60d
0x990eac: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x35deac
0xa07080: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x3d4080
0x9b97eb: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x3867eb
0x75e9b4: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x12b9b4
(ScDocShell::AdjustRowHeight(long, long, short) + 0x5c)
0x8a3651: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x270651
0xab65c9: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x4835c9
0xabb607: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x488607
0xaa6691: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x473691
0x7541f8: /usr/lib/openoffice.org2.0/program/libsc680li.so + 0x1211f8
(ScDocShell::ConvertFrom(SfxMedium&) + 0x486)
0x20727f0: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1237f0
(SfxObjectShell::DoLoad(SfxMedium*) + 0xe02)
0x20a3ed8: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x154ed8
(SfxBaseModel::load(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>
const&) + 0x42c)
0x20c118b: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x17218b
0x23028ab: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xea8ab
0x2302ac3: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xeaac3
0x23030f8: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xeb0f8
0x224e155: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x36155
0x30e39f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x3539f
(desktop::DispatchWatcher::executeDispatchRequests(_STL::vector<desktop::DispatchWatcher::DispatchRequest,
_STL::allocator<desktop::DispatchWatcher::DispatchRequest> > const&) + 0x102b)
0x30700b: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x2e00b
(desktop::OfficeIPCThread::ExecuteCmdLineRequests(desktop::ProcessDocumentsRequest&)
+ 0x15d)
0x2fe971: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x25971
(desktop::Desktop::OpenClients() + 0xe7b)
0x2feadf: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x25adf
(desktop::Desktop::OpenClients_Impl(void*) + 0x35)
0x2feb36: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x25b36
(desktop::Desktop::LinkStubOpenClients_Impl(void*, void*) + 0x1a)
0x3353a7a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7ca7a
0x34ae51d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d751d
0x29af3da: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1d3da
0x29d2dc2: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x40dc2
(SalDisplay::DispatchInternalEvent() + 0x64)
0x296505c: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1405c
0x28dc5e1: /lib/libglib-2.0.so.0 + 0x295e1
0x28de342: /lib/libglib-2.0.so.0 + 0x2b342 (g_main_context_dispatch + 0x182)
0x28e131f: /lib/libglib-2.0.so.0 + 0x2e31f
0x28e1885: /lib/libglib-2.0.so.0 + 0x2e885 (g_main_context_iteration + 0x65)
0x2964033: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x13033
0x29d51f9: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x431f9
(X11SalInstance::Yield(unsigned char) + 0x27)
0x335beb0: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x84eb0
(Application::Yield() + 0x48)
0x335bf34: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x84f34
(Application::Execute() + 0x26)
0x2fb929: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x22929
(desktop::Desktop::Main() + 0x15c1)
0x335fcc2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x88cc2
0x335fd75: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x88d75 (SVMain()
+ 0x2b)
0x2f5699: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1c699 (sal_main +
0x5d)
0x2f56e5: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1c6e5 (main + 0x27)
0x340214: /lib/libc.so.6 + 0x19214 (__libc_start_main + 0xdc)
0x80484a1: /usr/lib/openoffice.org2.0/program/scalc.bin + 0x4a1


Expected results:
File should just load

Additional info:
Comment 1 Paul F. Johnson 2006-08-08 10:35:55 EDT
Created attachment 133790 [details]
File which causes the crash
Comment 2 Caolan McNamara 2006-08-08 10:40:01 EDT

*** This bug has been marked as a duplicate of 201546 ***

Note You need to log in before you can comment on or make changes to this bug.