Bug 20172 - depmod errors when installing ext3 kernel.
depmod errors when installing ext3 kernel.
Status: CLOSED CURRENTRELEASE
Product: Red Hat High Availability Server
Classification: Retired
Component: ext3 (Show other bugs)
beta
i586 Linux
low Severity low
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-01 20:06 EST by Sam Varshavchik
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 17:32:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-11-01 20:06:18 EST
I'm in the process of loading the ext3 kernel onto a laptop.  My first step
was to install the 10-31-2000 kernel build.  This is what I got:

[root@laptop /root]# rpm -i kernel-2.2.17-6.i586.rpm
depmod: depmod.c:575: addksyms: Assertion `n_syms < 10000' failed.
var/tmp/rpm-tmp.80957: line 5:  1017 Aborted                 (core dumped)
depmod -a -i -m /boot/System.map-2.2.17-6 2.2.17-6

The kernel RPM did install, but depmod failed.  This was the depmod from
the 7.0 modutils-2.3.14-3.  I manually upgraded modutils next, then I took
a look at rpm -q --scripts kernel-2.2.17-6, and picked up where it left
off:

[root@laptop /boot]# depmod -a -i -m /boot/System.map-2.2.17-6 2.2.17-6
depmod: not an ELF file

This appears to be a spurious message, because depmod did exit with 0. 
There does not appear to be anything else remaining in the script that I
care about.  I do not have conf.modules, and I do not have any scsi
adapters on this laptop.

This is still an upgrade issue, though.  When upgrading from 2.2.16, it
looks like it is necessary to upgrade modutils first, before kernel.
Comment 1 Red Hat Bugzilla 2000-11-01 20:09:58 EST
I straced depmod, trying to pick up where that spurious message comes from, this
is what I got:

open("/lib/modules/2.2.17-6/.rhkmvtag", O_RDONLY) = 4
lseek(4, 0, SEEK_SET)                   = 0
read(4, "Linux version 2.2.17-6 (root@por"..., 52) = 52
write(2, "depmod: ", 8)                 = 8
write(2, "not an ELF file", 15)         = 15
write(2, "\n", 1)                       = 1
close(4) 

Does depmod think that .rhkmvtag is a module???
Comment 2 Red Hat Bugzilla 2000-11-02 05:22:16 EST
You need a more recent modutils, indeed.  I'm using 2.3.11-1 on 6.2 and 2.3.17-3
on 7.0.

The "depmod: not an ELF file" is a warning that you can safely ignore, and has
to do with the way depmod deals with the various files recent kernels leave in
/lib/modules rather than ext3 itself.

Unfortunately I can't do a dependency on modutils in the kernel RPM, because the
existing modutils don't always supply an appropriately versioned "provides"
symbol to key on.

Assigned to our brave kernel builder, who knows far more than I about what
tricks RPM can play to make sure that we have modutils running correctly.
Comment 3 Red Hat Bugzilla 2001-05-07 15:04:38 EDT
Is this still a problem?
Comment 4 Red Hat Bugzilla 2001-05-07 17:32:21 EDT
No.

Note You need to log in before you can comment on or make changes to this bug.