Bug 20174 - a bug that may slows down the performance of Linux
a bug that may slows down the performance of Linux
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: magicdev (Show other bugs)
7.0
i586 Linux
high Severity high
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-01 22:49 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 21:31:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-01 22:49:57 EST
I am using Redhat 7.0 on my pentium II computer with 256M ram. Also, I 
have two SCSI harddisks and 1 IDE CD-Rom Drive. After upgrading from 
Redhat 6.2 to 7.0 , a message always displays on the screen "hda: ATAPI 
40X CD-ROM Drive, 128kb Cache". The screen is full of this text. After I 
press any key then the cursor comes back. I also sometimes need to re-boot 
the computer to restart the installed sendmail service on that computer 
because the computer performance is slow down. Many staff in my company 
complain about the dis-continue of email service.

Where is the source of the bug?
How can I fix it?

Best regards,

Timmy
Comment 1 Bill Nottingham 2000-11-02 01:07:17 EST
The IDE CD-ROM message is very likely coming from magicdev.
You may want to consider disabling it.

You should also make sure you're running the latest
updates.
Comment 2 Owen Taylor 2001-02-07 21:31:02 EST
I think the performance problems (whatever they are) they are unrelated
to the  messages. The kernel messages are harmless and are generated 
every 10 minutes when /etc/cron.d/kmod removes the module, and then
magicdev reloads it next time it checks for the presence of a
CDROM device. (This check occurs every two seconds.)

It's strange a little that you are getting the kernel messages directed
to your screen - by default, all kernel messages are logged to
syslogd and should show up in /var/log/messages. At a rate
of once every 10 minutes, and considering that syslog removes
duplicate messages, I would not consider this a major problem.

If you do ps auxw | grep klogd, what does that show? It's possible
that klogd is not running on your system for some reason, which
would disable the redirection of error messages.

Did turning off magicdev fix the performance problems?

Thanks,
                                    Owen
Comment 3 Elliot Lee 2001-03-13 18:25:18 EST
No reply after more than a month... closing.

Note You need to log in before you can comment on or make changes to this bug.