Bug 201832 - acpi_cpufreq not loading from rawhide kernel
acpi_cpufreq not loading from rawhide kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-09 04:46 EDT by Paul F. Johnson
Modified: 2015-01-04 17:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 01:54:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg for when I boot up (18.25 KB, text/plain)
2006-08-09 04:46 EDT, Paul F. Johnson
no flags Details

  None (edit)
Description Paul F. Johnson 2006-08-09 04:46:54 EDT
Created attachment 133838 [details]
dmesg for when I boot up
Comment 1 Paul F. Johnson 2006-08-09 04:46:54 EDT
Description of problem:
Using a Toshiba Satellite Pro A10. I have the cpufreq option set on services
which causes the module to be loaded during the kernel loadup. However, during
load up, I get an error that acpi_cpufreq cannot be loading - invalid argument

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2530.fc6

How reproducible:
Always

Steps to Reproduce:
1. Start machine
2.
3.
  
Actual results:
see dmesg file attached

Expected results:
acpi_cpufreq should load - it has in the past

Additional info:

Not sure if this is related to the other cpufreq bug already reported, though
this is in rawhide and they seem to be FC4 related.
Comment 2 Dan Horák 2006-08-16 08:15:51 EDT
I am seeing the same, could be a compatibility problem with ACPI vs. SMP kernel?
Notebook is Quanta ZW9.
Comment 3 Dan Horák 2006-08-17 08:45:40 EDT
2.6.17-1.2571.fc6 still the same
Comment 4 Dan Horák 2006-08-21 15:24:15 EDT
2.6.17-1.2573.fc6 still the same, I have also recompiled this kernel without SMP
which made the acpi_cpufreq 116 KB big (instead of 16 KB in the SMP variant),
but it still doesn't work

Comment 5 Clyde E. Kunkel 2006-08-25 13:27:23 EDT
Not a notebook, but on asus P4C800E-Deluxe workstation boot after entering
runlevel 5 and just after Checking for hardware changes:

Starting readahead early: Starting background readahead     [ok]
                                                            [ok]
Checking for hardware changes
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.17-1.2586.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
Invalid argument  (hand transcried from digital pic of boot sequence. No msgs in
/var/log that I can find)
Bringing up loopback interface                              [ok]
etc...

This error has benn present for some time, but doesn't seem to affect anything
on this workstation.  

HTH
Comment 6 Clyde E. Kunkel 2006-08-25 14:01:28 EDT
Did an interactive startup and the error msg in comment #5 shows up immediately
after Starting cpuspeed.
Comment 7 Clyde E. Kunkel 2006-08-25 16:10:18 EDT
Googling acpi_cpufreq was beneficial.  Found the following which fixed problem
for me.

http://www.redhat.com/archives/rhl-list/2005-November/msg03164.html

Comment 8 Jason 2006-08-28 12:39:38 EDT
I have this problem too.  My system is a tyan tiger 100 (S1832) dual processor
capable (only 1 P3 850Mhz installed) with 256MB of RAM.
Comment 9 Jason 2006-08-29 17:11:58 EDT
Still happens on  2.6.17-1.2597.fc6
Comment 10 Clyde E. Kunkel 2006-08-29 19:22:24 EDT
I wonder if this is a kernel problem?  Would it not be initscripts/cpuspeed 
since /etc/cpuspeed.conf DEVICE= is not being initialized properly?  Who/what 
is supposed to provide the proper module name in cpuspeed.conf?
Comment 11 Jason 2006-09-01 12:13:23 EDT
I think Clyde is right in that this is a cpuspeed problem.  
Comment 12 Dan Horák 2006-09-06 07:45:40 EDT
It WORKS again in current kernel 2.6.17-1.2617.2.1.fc6
Comment 13 Jason 2006-09-09 10:56:43 EDT
it works for me in kernel 2.6.17-1.2630.fc6.  I did not try 2617.2.1.fc6

Thanks,
Comment 14 Dan Horák 2006-09-09 14:47:26 EDT
kernel 2.6.17-1.2630.fc6 works for me too

Note You need to log in before you can comment on or make changes to this bug.