Bug 202009 - powernow-k8: fid trans failed, fid 0xc, curr 0xe
powernow-k8: fid trans failed, fid 0xc, curr 0xe
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On: 191566
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-10 07:23 EDT by Alan Cox
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version: kernel-xen-2.6.18-1.2767.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 09:36:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2006-08-10 07:23:15 EDT
+++ This bug was initially created as a clone of Bug #191566 +++

Description of problem:

Seeing a fair number of:

powernow-k8: fid trans failed, fid 0xc, curr 0xe
powernow-k8: transition frequency failed

# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 43
model name      : AMD Athlon(tm)64 X2 Dual Core Processor  4200+
stepping        : 1
cpu MHz         : 2200.000
cache size      : 512 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext
3dnow pni lahf_lm cmp_legacy
bogomips        : 5527.18
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp

(cpu #1 deleted)


Version-Release number of selected component (if applicable):
2.6.16-1.2111_FC5xen0
Comment 1 Alan Cox 2006-08-10 07:32:20 EDT
Seeing the same with FC6test2 and the Xen kernel - spews powernow errors every
second or so, with high urgency level that spew all over the console. Not sure
if this is a Xen related bug (no powernow and it shouldnt be enabled) or a
kernel one.
Comment 2 Chris Lalancette 2006-08-10 10:25:40 EDT
This seems to be Xen specific.  When the Xen dom0 boots up, the powernow-k8_init
function is called, which goes around to each CPU to query whether it supports
frequency and voltage transition.  All of this is read-only, so all of the calls
to access the various feature flags of the CPU succeed, and the code thinks that
the processor is capable of the transitions.  However, later on, when it
actually tries to do the transition, the Hypervisor prevents the write to the
MSR register, which fails the frequency change, which causes the messages to be
continually output.  This can be further seen by looking at the messages coming
out of both the Hypervisor and the dom0 kernel:

(XEN) (file=traps.c, line=1385) Domain attempted WRMSR 00000000c0010041 from
00.powernow-k8: fid trans failed, fid 0x10, curr 0x12
powernow-k8: transition frequency failed
Comment 3 Jordan Russell 2006-08-13 20:33:16 EDT
Patch here (haven't tested myself):

http://groups.google.com/group/xen-devel-archive/browse_thread/thread/dd1794f10ecf69aa/23a55071d651ee28
Comment 4 Alan Cox 2006-08-31 05:32:27 EDT
Still present in the -200 kernel from rawhide yesterday
Comment 5 Alan Cox 2006-10-02 18:54:34 EDT
Still present in FC6Pre - spewed all over the console, message level regardless
and makes Xen unusuable on the afflicted systems.
Comment 6 Dave Jones 2006-11-06 23:48:52 EST
I was under the impression we were disabling CPU_FREQ for Xen for now until some
sanity gets beaten into it on the Xen side.
Comment 7 Stephen Tweedie 2006-11-07 09:36:30 EST
It was disabled on Oct. 11.

Note You need to log in before you can comment on or make changes to this bug.