Bug 202011 - acpi=off required for RHCS nodes, not mentioned in official documentation
Summary: acpi=off required for RHCS nodes, not mentioned in official documentation
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rh-cs-en   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Kennedy
QA Contact: Cluster QE
URL: http://www.redhat.com/docs/manuals/cs...
Whiteboard:
Keywords: Documentation
Depends On:
Blocks: 429359
TreeView+ depends on / blocked
 
Reported: 2006-08-10 11:29 UTC by Riaan van Niekerk
Modified: 2015-04-20 00:47 UTC (History)
5 users (show)

Fixed In Version: 4.5, 4.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 22:09:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Excerpt of section, "Configuring ACPI For Use with Integrated Fence Devices" for new chapter, "Before Configuring a Red Hat Cluster" in Cluster Administration Guide (73.75 KB, text/pdf)
2007-08-29 19:02 UTC, Paul Kennedy
no flags Details

Description Riaan van Niekerk 2006-08-10 11:29:47 UTC
Description of problem:

According to some posts on linux-cluster@redhat.com, by Lon Hohberger, acpi 
should be disabled when using integrated fencing (ILO, DRAC, IPMI, etc)

The official documentation does not mention anything in this regard. Can you  
please update the documentation to reflect this, if it is a firm requirement 
by Red Hat, and explicitly for which modules.
(personally I would include/mention acpi=ht or some less extreme variant of 
acpi=off)

Additional info:
Postings where acpi=off is mentioned:
https://www.redhat.com/archives/linux-cluster/2006-August/msg00035.html
https://www.redhat.com/archives/linux-cluster/2006-August/msg00082.html

Comment 1 Riaan van Niekerk 2006-08-10 11:36:54 UTC
HTML-version of where this should probably be added, chapter/section 2.4
http://www.redhat.com/docs/manuals/csgfs/browse/rh-cs-en/s1-hardware-linux.html

Comment 2 Paul Kennedy 2006-10-19 14:44:54 UTC
Will add to currently published book.

Comment 3 Lon Hohberger 2007-02-13 20:54:40 UTC
Note that in most cases:

    chkconfig --del acpid

... and rebooting should be sufficient to disable ACPI soft-off.  Because some
machines do not behave well with "acpi=off" in the kernel command line, it is
probably best left as a last resort rather than an initial fix.

* Some machines have toggles in the BIOS setup which allows you to set the power
button to "soft-off", "4-second off", or "instant-off" - you'll always want
"instant-off"

* If acpid is not running (and not enabled during system boot) and the fence
agent still fails to power off the machine immediately, then try adding
"acpi=off" to the kernel boot command line.

Historically, we've told people to do this as well as stop/disable acpid.

Comment 4 Kiersten (Kerri) Anderson 2007-05-21 22:18:19 UTC
Moving this bug to the 4.6 release since 4.5 has already been released.

Comment 10 Paul Kennedy 2007-08-29 19:02:29 UTC
Created attachment 179601 [details]
Excerpt of section, "Configuring ACPI For Use with Integrated Fence Devices"  for new chapter, "Before Configuring a Red Hat Cluster" in Cluster Administration Guide

Comment 11 Paul Kennedy 2007-08-29 19:06:06 UTC
New content created (see attachment from Comment #10) and reviewed for technical
accuracy. New content will be published with RHEL 4.5 and RHEL 4.6.

Comment 12 Paul Kennedy 2007-08-29 19:08:50 UTC
Also will be published with currently supported RHEL 5 documentation.

Comment 13 Michael Hideo 2007-10-23 02:49:33 UTC
Removing automation notification

Comment 14 Paul Kennedy 2008-01-16 22:09:35 UTC
New content is available on this page:
http://www.redhat.com/docs/manuals/csgfs/


Note You need to log in before you can comment on or make changes to this bug.