Bug 202025 - Hardware Accelerated 3d broken in 1.6.4-3
Hardware Accelerated 3d broken in 1.6.4-3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-10 09:36 EDT by Kevin DeKorte
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 11:20:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log file (64.01 KB, text/plain)
2006-08-10 09:36 EDT, Kevin DeKorte
no flags Details

  None (edit)
Description Kevin DeKorte 2006-08-10 09:36:53 EDT
Description of problem:
Running the previous 1.6.0-17 driver hardware accelerated 3d worked great. I
upgraded to xorg-x11-drv-i810-1.6.4-3.fc6 and now hardware 3d is broken.


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.6.4-3.fc6

How reproducible:
100%

Steps to Reproduce:
1.Install the driver
2.run glxinfo
3.
  
Actual results:
 glxinfo
name of display: :0.0

ERROR!  sizeof(I830DRIRec) does not match passed size from device driver
libGL warning: 3D driver returned no fbconfigs.
libGL error: InitDriver failed
libGL error: reverting to (slow) indirect rendering
display: :0  screen: 0
direct rendering: No


Expected results:
direct rendering should be on

Additional info:
I have the kernel vga option set. I will retry with it unset.
Comment 1 Kevin DeKorte 2006-08-10 09:36:56 EDT
Created attachment 133946 [details]
Log file
Comment 2 Adam Jackson 2006-08-10 13:47:01 EDT
This is going to suck, I think.  I believe I830DRIRec changed _again_ in 1.6.4,
which means mesa is broken.  But, if I fix it, I'd probably need to cross-port
the 1.6.4 DRI code to the modesetting driver.  Hmm.
Comment 3 Kevin DeKorte 2006-08-10 14:36:52 EDT
According to the website at http://intellinuxgraphics.org//user.html (under the
Mac Mini section) a version of the driver that includes modesetting is in
development so maybe that would work? They also have a version of Mesa on that
site that works with the driver. 

Or is it possible to have a I820DRIRec160 structure in Mesa so the 1.6.0 driver
can get the info in needs from that structure?
Comment 4 Adam Jackson 2006-08-10 19:37:03 EDT
(In reply to comment #3)
> According to the website at http://intellinuxgraphics.org//user.html (under the
> Mac Mini section) a version of the driver that includes modesetting is in
> development so maybe that would work? They also have a version of Mesa on that
> site that works with the driver. 

When they say "in development" they mean "yeah, we're going to start developing
that soon".

> Or is it possible to have a I820DRIRec160 structure in Mesa so the 1.6.0 driver
> can get the info in needs from that structure?

I think they have to be laid out identically.  Not a big deal though; working on it.
Comment 5 Kevin DeKorte 2006-08-13 20:59:47 EDT
Alan,

It looks like the 1.6.5 driver is out and might fix the backward compatiblity
with the 1.6.0 driver..

http://lists.freedesktop.org/archives/xorg/2006-August/017449.html

Kevin
Comment 6 Kevin DeKorte 2006-08-14 09:54:27 EDT
Just as a follow up. I installed just the  xf86-video-i810-1.6.5 driver on my
rawhide system. I compiled it from source and used all the normal rawhide mesa
and other drivers. With that setup I am able to get 3d acceleration working
fine. So I think if you just upgrade the driver rpm that should be enough.
Comment 7 Adam Jackson 2006-08-14 11:20:38 EDT
(In reply to comment #6)
> Just as a follow up. I installed just the  xf86-video-i810-1.6.5 driver on my
> rawhide system. I compiled it from source and used all the normal rawhide mesa
> and other drivers. With that setup I am able to get 3d acceleration working
> fine. So I think if you just upgrade the driver rpm that should be enough.

Cool.  I'm building this in rawhide now, should come out as 1.6.5-1.  Thanks!
Comment 8 Kevin DeKorte 2006-08-14 14:18:31 EDT
A little more follow up on this.

compiz and the desktop effects work great with the 1.6.5 driver. However, things
that you run under that like google earth, glxgears, ppracer etc. Basically any
thing opengl flicker REALLY aweful. I think it is the desktop effects of compiz.
Because if I disable desktop effects then all that stuff works fine. I had
thought that the flickering issue had been fixed/reduced with an eariler version
of the driver. 
Comment 9 Kevin DeKorte 2006-08-16 10:44:58 EDT
I know this bug is closed, but I did want to say that after I got all the latest
RPM drivers everything is working great. compiz, ppracer etc all seem pretty good.

Note You need to log in before you can comment on or make changes to this bug.