Bug 20203 - XFree86 doesn't restore key repeat rate after apm resume
Summary: XFree86 doesn't restore key repeat rate after apm resume
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-02 11:39 UTC by mikpe
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-05 10:46:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mikpe 2000-11-02 11:39:33 UTC
The machine is a Dell Latitude CPi 266XT, Neomagic graphics chipset.
In RH7 with XFree86-SVGA, I find that whenever I resume the machine
from apm suspend, the key repeat rate has been changed to something
extremely slow. I normally use xset r rate 250 25.

An "xset r rate 250 25" after suspend does not work, since xset
believes that this rate is current. Instead I have to issue TWO
xset commands: "xset r rate 5 5; xset r rate 250 25" to force
the change.

This was not a problem in previous RH releases. Before RH7, I used
the XFree86 libraries but the commercial Accelerated-X server
(since Neomagic wasn't supported by XFree86 until recently).
However, "xset r rate .. .." doesn't work with this server and the
RH7 XFree86 libraries (something about some XFree-Misc missing).

This is so annoying I'm considering downgrading to the RH6.2 XFree
libraries and reinstalling the Accellerated-X server.

Comment 1 Gaetan Minet 2000-11-07 17:01:37 UTC
Same problem on a dell inspiron 7000. I think it's Dell specific.
I simply use "kdbrate -r 24 -d 250" instead and all works fine (both x and
consoles).

Comment 2 Mike A. Harris 2001-06-05 06:46:28 UTC
To the original poster:  Can you provide me the _exact_ error you get?

Also, what does "rpm -qa |sort|grep '^X'" report?


Comment 3 mikpe 2001-06-05 10:46:19 UTC
Since upgrading to RH7.1 my Dell laptop no longer has a problem
with bogus key repeat rate after resume.



Comment 4 Mike A. Harris 2001-07-16 07:56:53 UTC
Ok, marking fixed in current.


Note You need to log in before you can comment on or make changes to this bug.