Bug 202077 - eclipse internal error in CDT
eclipse internal error in CDT
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnston
:
: 208854 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-10 14:25 EDT by Tom Tromey
Modified: 2014-08-11 01:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-26 14:17:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 29362 None None None Never

  None (edit)
Description Tom Tromey 2006-08-10 14:25:35 EDT
I'm seeing an internal error with the CDT.
Offhand it appears to be a Classpath bug of some kind.

Here is the stack trace.  I don't recall what I was doing
when this appeared.

!ENTRY org.eclipse.cdt.make.core 4 2 2006-08-09 22:37:34.822
!MESSAGE Problems occurred when invoking code from plug-in:
"org.eclipse.cdt.make.core".
!STACK 0
java.lang.NullPointerException
   at gnu.xml.transform.TransformerImpl.strip(libgcj.so.7rh)
   at gnu.xml.transform.TransformerImpl.strip(libgcj.so.7rh)
   at gnu.xml.transform.TransformerImpl.strip(libgcj.so.7rh)
   at gnu.xml.transform.TransformerImpl.transform(libgcj.so.7rh)
   at
org.eclipse.cdt.make.internal.core.scannerconfig.DiscoveredScannerInfoStore.saveDiscoveredScannerInfoToState(org.eclipse.cdt.make.core_3.1.0.200607251301.jar.so)
   at
org.eclipse.cdt.make.internal.core.scannerconfig.DiscoveredPathManager.updateDiscoveredInfo(org.eclipse.cdt.make.core_3.1.0.200607251301.jar.so)
   at
org.eclipse.cdt.make.internal.core.scannerconfig2.PerProjectSICollector.updateScannerConfiguration(org.eclipse.cdt.make.core_3.1.0.200607251301.jar.so)
   at
org.eclipse.cdt.make.internal.core.scannerconfig.jobs.SCJobsUtil$2.run(org.eclipse.cdt.make.core_3.1.0.200607251301.jar.so)
   at
org.eclipse.core.runtime.SafeRunner.run(org.eclipse.equinox.common_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.runtime.Platform.run(org.eclipse.core.runtime_3.2.0.v20060603.jar.so)
   at
org.eclipse.cdt.make.internal.core.scannerconfig.jobs.SCJobsUtil.updateScannerConfiguration(org.eclipse.cdt.make.core_3.1.0.200607251301.jar.so)
   at
org.eclipse.cdt.make.core.scannerconfig.ScannerConfigBuilder.build(org.eclipse.cdt.make.core_3.1.0.200607251301.jar.so)
   at
org.eclipse.core.internal.events.BuildManager$2.run(org.eclipse.core.resources_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.runtime.SafeRunner.run(org.eclipse.equinox.common_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.internal.events.BuildManager.basicBuild(org.eclipse.core.resources_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.internal.events.BuildManager.basicBuild(org.eclipse.core.resources_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.internal.events.BuildManager$1.run(org.eclipse.core.resources_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.runtime.SafeRunner.run(org.eclipse.equinox.common_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.internal.events.BuildManager.basicBuild(org.eclipse.core.resources_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.internal.events.BuildManager.basicBuildLoop(org.eclipse.core.resources_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.internal.events.BuildManager.build(org.eclipse.core.resources_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.internal.events.AutoBuildJob.doBuild(org.eclipse.core.resources_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.internal.events.AutoBuildJob.run(org.eclipse.core.resources_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.internal.jobs.Worker.run(org.eclipse.core.jobs_3.2.0.v20060603.jar.so)
Comment 1 Jeff Johnston 2006-10-05 17:17:29 EDT
The bug has been isolated to a stand-alone test which doesn't use any Eclipse
classes.  A bug 29362 has been opened against libgcj.
Comment 2 Jeff Johnston 2006-10-26 14:17:42 EDT
A patch has been made for 29362 that fixes the specified problem.
Comment 3 Jeff Johnston 2006-11-01 14:54:43 EST
*** Bug 208854 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.