Bug 2021 - timezone global changes with daylight savings time
timezone global changes with daylight savings time
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-06 06:24 EDT by david.wilson
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-18 12:36:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david.wilson 1999-04-06 06:24:04 EDT
The man page, the SVID, and the behaviour of libc5 all
had the timezone global containing the offset from GMT
of the standard timezone. (e.g. EST).

I have found that with RH5.1 (libc 2.0.7) that the value
of timezone depends, e.g. on the last call to localtime, and
the value is the offset from GMT of the time last reported.
If daylight savings time is in effect for this converted
time, then timezone is the DST timezone, not the standard
timezone.

For my locale (GB), calling localtime with a time in
December, gives a timezone value of 0, which is correct.
But calling localtime with a time in April, gives a timezone
value of -3600, which is not correct.
Comment 1 Michael K. Johnson 1999-04-09 23:07:59 EDT
Is your hardware clock set to UTC?
Does /etc/sysconfig/clock have
UTC=true
in it?
Comment 2 Cristian Gafton 1999-06-18 12:36:59 EDT
closed because of lack of feedback. Please reopen for follow ups.


------- Email Received From  David Wilson <David.Wilson@MessagingDirect.com> 06/18/99 13:09 -------

Note You need to log in before you can comment on or make changes to this bug.