Bug 202172 - up2date fails with ImportError: No module named rpm
up2date fails with ImportError: No module named rpm
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-11 07:26 EDT by Mirjam van den Hout - van Vroonhoven
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 11:45:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of failing up2date command (1.81 KB, text/plain)
2006-08-11 07:26 EDT, Mirjam van den Hout - van Vroonhoven
no flags Details

  None (edit)
Description Mirjam van den Hout - van Vroonhoven 2006-08-11 07:26:22 EDT
Description of problem:

During run of up2date, up2date got updated, and up2date run restarted
automatically. The restarted up2date (and all subsequent calls to up2date)
fails with:

  Restarting up2date
  Traceback (most recent call last):
    File "/usr/sbin/up2date-nox", line 11, in ?
      import rpm
  ImportError: No module named rpm
  [root@bioinf-dual07 ~]#

Version-Release number of selected component (if applicable):

During the first up2date run the following packages got upgraded:
  rhnlib         from version 1.8.2-1.p23.1 to version 1.8.7-4
  up2date                     4.4.67-4                 4.4.69-25
  up2date-gnome               4.4.67-4                 4.4.69-25

Downgrading again (rpm -Uhv --oldpackage) to the versions before the upgrade
does not solve the issue.

How reproducible:
I have no idea how to reproduce. This happened during the up2date run on 1
machine, 7 others updated fine.

Steps to Reproduce:
  run up2date-nox -u
  
Actual results:
Any attempt to start up2date now fails with
  Traceback (most recent call last):
    File "/usr/sbin/up2date-nox", line 11, in ?
      import rpm
  ImportError: No module named rpm

Expected results:
up2date runs successfull

Additional info:
It might have to do with the technical problems RedHat Network / Up2date server
was experiencing today.
Comment 1 Mirjam van den Hout - van Vroonhoven 2006-08-11 07:26:23 EDT
Created attachment 134010 [details]
Output of failing up2date command
Comment 2 Mirjam van den Hout - van Vroonhoven 2006-08-22 08:06:45 EDT
This is not a bug, but /usr/local/bin is in the path before /usr/bin/python, and
/usr/local/bin contained a newer version (2.4) of python.

I'm not allowed to change the status of this bug to NOTABUG, so can somebody at
redhat please do so?
Comment 3 Red Hat Bugzilla 2007-04-11 21:04:19 EDT
User bnackash@redhat.com's account has been closed

Note You need to log in before you can comment on or make changes to this bug.