Bug 202181 - [pa] Font Rendering issue for Punjabi
[pa] Font Rendering issue for Punjabi
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: i18n
Depends On:
Blocks: 209970
  Show dependency treegraph
 
Reported: 2006-08-11 08:46 EDT by A S Alam
Modified: 2013-07-02 20:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-27 10:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Font Test Case (161 bytes, text/plain)
2006-08-11 08:46 EDT, A S Alam
no flags Details
Image from QT (5.43 KB, image/png)
2006-08-11 08:48 EDT, A S Alam
no flags Details
Problem description (188.38 KB, image/png)
2006-10-03 04:51 EDT, Jaswinder Singh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 103938 None None None Never

  None (edit)
Description A S Alam 2006-08-11 08:46:56 EDT
Description of problem:
Rendering of following combination is incorrect ing PANGO
------
0a050a3e
0a720a3f
0a720a40
0a730a41
0a730a42
0a720a47
0a050a48
0a730a4b
0a050a4c
0a130a41

Consonant {0a15}+0a4d0a2f
------

for correct Rendering just open attached file in QT application (kedit/kate)
dotted circle is expected.

Version-Release number of selected component (if applicable):
pango-1.14.0-2


Additional Information:
Those combination are made by
{Cononent}+{Dependent Vowel}= {Indepentdent Vowel},
 U0AXX+ U0AYY= U0AXXYY {U0AZZ} (also have sepecific Unicode vowel)
it (U0AZZ) is just Visible to User, but actually it is U0AXXYY, user must
know that is not U0AZZ
Comment 1 A S Alam 2006-08-11 08:46:56 EDT
Created attachment 134015 [details]
Font Test Case
Comment 2 A S Alam 2006-08-11 08:48:46 EDT
Created attachment 134016 [details]
Image from QT
Comment 3 Behdad Esfahbod 2006-08-11 11:57:49 EDT
Right.  We don't support dotted circle in Pango yet...
Comment 4 Liang Zhang 2006-09-06 22:05:46 EDT
the same bug of upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=354711
Comment 5 Lawrence Lim 2006-10-03 03:42:22 EDT
Jas,
How important are these features in Punjabi?? Does it affect your work without them?
Comment 6 Jaswinder Singh 2006-10-03 04:50:56 EDT
> 0a050a3e ਅਾ
> 0a720a3f ੲਿ
> 0a720a40 ੲੀ
> 0a730a41 ੳੁ
> 0a730a42 ੳੂ
> 0a720a47 ੲੇ
> 0a050a48 ਅੈ
> 0a730a4b ੳੋ
> 0a050a4c ਅੌ
> 0a130a41 ਓੁ
> 
> Consonant {0a15}+0a4d0a2f ਕ੍ਯ


gedit - Inputting punjabi text and copy and paste works perfactly

kedit - inputting punjabi text is broken (Raw Code) but works perfectly with
pa-inscript. However when text is copied from punjabi (Raw Code) from Gedit to
kedit following broken rendering is observed (Screen Shot is attached)

Comment 7 Jaswinder Singh 2006-10-03 04:51:56 EDT
Created attachment 137631 [details]
Problem description
Comment 8 Jaswinder Singh 2006-10-03 04:54:31 EDT
> 0a050a3e ਅਾ
> 0a720a3f ੲਿ
> 0a720a40 ੲੀ
> 0a730a41 ੳੁ
> 0a730a42 ੳੂ
> 0a720a47 ੲੇ
> 0a050a48 ਅੈ
> 0a730a4b ੳੋ
> 0a050a4c ਅੌ
> 0a130a41 ਓੁ

These Inputs are very important for punjabi translation.
however note that the problem is only seen in raw unicode while pa-inscript
works perfectly with gedit and kedit.

jassy


Comment 9 Lawrence Lim 2006-10-09 00:22:02 EDT
Moving to Qt based on the screenshot supplied in Comment #7. Pango issue seems
to be resolved.
Comment 10 A S Alam 2006-10-19 02:34:48 EDT
following issued are fixed in *Pango* for Punjabi:
0a050a3e
0a720a3f
0a720a40
0a730a41
0a730a42
0a720a47
0a050a48
0a730a4b
0a050a4c
0a130a41
------
Only Pending issue is

Consonant {0a15}+0a4d0a2f ਕ੍ਯ 

need to fix in *QT* (already fixed in Pango)

tested with 
pango-1.14.6-3

**These are least important in Punjabi (Gurmukhi)
Comment 11 Liang Zhang 2006-10-19 04:02:37 EDT
I wrote a patch for this bug.
Please see:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=209970
Comment 12 Ngo Than 2006-10-27 10:30:35 EDT
it's fixed in 3.3.7-0.1.fc6. LingNing, thanks for the fix

Note You need to log in before you can comment on or make changes to this bug.