Bug 202204 - Enhancement request to pass authentication keys to ntpdate in startup script
Enhancement request to pass authentication keys to ntpdate in startup script
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ntp (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Brian Brock
: FutureFeature
: 245410 (view as bug list)
Depends On:
Blocks: 240141
  Show dependency treegraph
 
Reported: 2006-08-11 11:20 EDT by Colin Simpson
Modified: 2010-10-22 01:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0678
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Simpson 2006-08-11 11:20:15 EDT
Description of problem:
Our ntp servers only work with authentication keys. This stops ntpdate working
properly on startup. 

We therefore have to manually hack /etc/init.d/ntpd to allow ntpdate to work
properly on startup. 

There is no way to handle this situation in the present startup script which
simply has:

/usr/sbin/ntpdate $dropstr -s -b $tickers 2>/dev/null >/dev/null

Could either the startup scripts examine the $ntpconf file for not just the
server's IP but also maybe the optional key directive afterwards and pass this
to ntpdate.

Or a nastier way to simply allow an extra parameter to be passed from
/etc/sysconfig/ntpd

eg

/etc/sysconfig/ntpd:
# Drop root to id 'ntp:ntp' by default.
OPTIONS="-u ntp:ntp -p /var/run/ntpd.pid"

# Set to 'yes' to sync hw clock after successful ntpdate.
SYNC_HWCLOCK=no

NTPDATEOPTIONS="-a 11 -k /etc/ntp/keys"

/etc/init.d/ntpd:
/usr/sbin/ntpdate $dropstr $NTPDATEOPTIONS -s -b $tickers
Comment 1 Miroslav Lichvar 2006-08-14 07:02:44 EDT
Yes, this feature would be useful and I plan to implement it in devel. However,
it is not likely to be addressed in forthcoming updates for RHEL4. The primary
objectives of update releases are to enable new hardware platform support and to
resolve critical defects. If this issue is important to you, please contact Red
Hat Support.
Comment 2 Colin Simpson 2006-08-14 07:43:33 EDT
This issue does affect us but we can work around it in a grotty way, I'll ask
support if they'll consider it.
Comment 3 Miroslav Lichvar 2007-06-25 08:22:13 EDT
*** Bug 245410 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2008-07-24 15:34:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0678.html

Note You need to log in before you can comment on or make changes to this bug.