Bug 202229 - ixf86config repeatedly adds "### Comment all HorizSync and VertSync values to use DDC:" to xorg.conf
ixf86config repeatedly adds "### Comment all HorizSync and VertSync values to...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pyxf86config (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-11 13:48 EDT by Walter Neumann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-05 12:05:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walter Neumann 2006-08-11 13:48:11 EDT
Description of problem: The line 
### Comment all HorizSync and VertSync values to use DDC:
is repeatedly added to xorg.conf

Version-Release number of selected component (if applicable):
pyxf86config-0.3.24-1

How reproducible:
consistently

Steps to Reproduce:

1. run nvidia-config-display from the xorg-x11-drv-nvidia package of livna rpms
2. Check xorg.conf
3. Note that this appears to be a python bug, not a problem with the nvidia script
  
Actual results:
a new line "### Comment all HorizSync and VertSync values to use DDC:" has been
added to xorg.conf. Over time the xorg on my laptop grows enormous. 

Expected results:
xorg.conf should not be modified

Additional info:
The culprit seems to be ixf86configmodule.so.  This file includes the line that
is added.

The call to ixf86config that adds the relevant line may be:

#
# Adds a module to the Modules section.
# The module will only be listed once.
#
def addModule(modules, moduleName):
    m = ixf86config.XF86ConfLoad()
    m.name = moduleName
    removeModule(modules, moduleName)
    modules.load.insert(m)
Comment 1 Adam Jackson 2006-12-05 12:05:46 EST
Fixed in rawhide, will do FC6 update too.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.