Bug 202259 - Modify SELinux targeted policy to allow GCJ applet viewer execmem permissions
Modify SELinux targeted policy to allow GCJ applet viewer execmem permissions
Status: CLOSED DUPLICATE of bug 201038
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-11 16:26 EDT by louisgtwo
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 15:08:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description louisgtwo 2006-08-11 16:26:13 EDT
When I visited a page with an applet it froze firefox. I looked in the logs and
saw this:

Aug 11 15:13:55 soncomputer kernel: audit(1155323634.469:38): avc:  denied  {
execmem } for  pid=3198 comm="gappletviewer"
scontext=user_u:system_r:unconfined_t:s0
tcontext=user_u:system_r:unconfined_t:s0 tclass=process

GCJ applet viewer probably should be fixed in the future to not require execmem
permissions but meanwhile the SELinux targeted policy can be modified to allow this.
Comment 1 Andrew Haley 2006-08-12 03:47:28 EDT
This is a duplicate of the RHEL bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=201038

I'm not sure it makes any sense to trace these separately.
Comment 2 Daniel Walsh 2006-09-18 15:08:14 EDT

*** This bug has been marked as a duplicate of 201038 ***
Comment 3 Fedora Update System 2007-03-07 17:55:39 EST
ekiga-2.0.1-5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.