This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 202320 - libvirt-devel missing dependencies
libvirt-devel missing dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-12 15:18 EDT by Steven Pritchard
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 11:35:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
spec patch (502 bytes, patch)
2006-08-12 15:18 EDT, Steven Pritchard
no flags Details | Diff
Updated spec patch (536 bytes, patch)
2006-08-18 15:59 EDT, Steven Pritchard
no flags Details | Diff

  None (edit)
Description Steven Pritchard 2006-08-12 15:18:08 EDT
libvirt-devel contains libvirt.pc, but it does not have a dependency on 
pkgconfig.  There was a thread on fedora-packaging about this a couple of 
months ago, and the best reason for including the hard dependency was that 
otherwise the pkgconfig directory could be un-owned.

http://www.redhat.com/archives/fedora-packaging/2006-June/msg00178.html
Comment 1 Steven Pritchard 2006-08-12 15:18:09 EDT
Created attachment 134090 [details]
spec patch
Comment 2 Steven Pritchard 2006-08-18 15:58:39 EDT
It looks like libvirt-devel is also missing a dependency on xen-devel as well.
Comment 3 Steven Pritchard 2006-08-18 15:59:50 EDT
Created attachment 134472 [details]
Updated spec patch
Comment 4 Daniel Veillard 2006-11-06 11:35:06 EST
Okay, agreed except the Requirement on xen-devel should not be
tied to a specific version, applied, pushing it, it should be fixed in
Rawhide soonish,

  thanks

Daniel

Note You need to log in before you can comment on or make changes to this bug.