Bug 202337 - Kernel boot message: "BIOS bug: Legacy-free FADT detected, but FADT size (129) is incorrect!"
Kernel boot message: "BIOS bug: Legacy-free FADT detected, but FADT size (129...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Paris
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-12 21:18 EDT by Niksa Jurinovic
Modified: 2007-11-16 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-11 15:38:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel log (16.18 KB, text/plain)
2006-08-12 21:18 EDT, Niksa Jurinovic
no flags Details
Intel-BIOS specs in Adobe Acrobat PDF (17.51 KB, application/pdf)
2006-08-30 16:38 EDT, Niksa Jurinovic
no flags Details

  None (edit)
Description Niksa Jurinovic 2006-08-12 21:18:09 EDT
KERNEL: kernel-2.6.9-42.EL
 GLIBC: glibc-2.3.4-2.25

After updating RHEL4.3 AS to RHEL4.4 AS for Linux x86, I'm getting kernel boot
warning message: 

"BIOS bug: Legacy-free FADT detected, but FADT size (129) is incorrect!"

on every system startup. I've never seen that message on the same machine before
(FC2, FC3, FC4, RHEL3, RHEL4.0-3, Win XP, Win Server 2003). 

For more information see attached 'dmesg.txt' file.
Comment 1 Niksa Jurinovic 2006-08-12 21:18:10 EDT
Created attachment 134093 [details]
kernel log
Comment 2 Jason Baron 2006-08-22 14:42:03 EDT
hmmm, is there any actual bugs or problems, besides the log messages?
Comment 3 Konrad Rzeszutek 2006-08-22 15:17:44 EDT
The patch that is causing this to show up was to fix a bug with a BIOS having an
incorrect size FADT table - and since Linux used that table to get the ACPI
registers for reboot and they were invalid (b/c it read 0 instead of the right
values as the FADT was truncated), the machine couldn't reboot. The patch
inserted logic to reboot the machine using the keyboard controller instead of
the ACPI. The problem (reboot) is specific to certain machines with certain BIOS
version.

The message is harmless. It can be removed, ignored, etc.
Comment 4 Niksa Jurinovic 2006-08-26 14:34:37 EDT
(In reply to comment #2)
> hmmm, is there any actual bugs or problems, besides the log messages?

No, no probelems at all.
Comment 5 Eric Paris 2006-08-30 14:45:30 EDT
This code path is when bios vendors attempt to implement an interim (between
acpi 1.0b and 2.0) FADT acpi section we use to support ACPI reboot.  It does not
appear that your bios vendor did it the same way we expect.  Since there is not
really one true standard that I can find I can't say for SURE it is the bios who
is wrong.  I would suggest either just ignoring this message or talk to your
bios vendor asking them why their table size is only 129 bytes long when it
should be 132 bytes.

As of right now I do not believe this is a linux bug and as long as your system
is rebooting ok you can just ignore it.  If you get more information from your
bios vendor I would love to hear it.
Comment 6 Niksa Jurinovic 2006-08-30 16:38:07 EDT
Created attachment 135243 [details]
Intel-BIOS specs in Adobe Acrobat PDF
Comment 7 Niksa Jurinovic 2006-08-30 16:43:44 EDT
Board: Intel Corporation D845EBG2 AAA82888-205
Serial Number: CF2B22727004
Bus Clock: 100 megahertz
BIOS: Intel Corp. PT84520A.86A.0015.P08.0302261328 02/26/2003

This is the last Intel-BIOS upgrade for this board.
 
(In reply to comment #5)
> This code path is when bios vendors attempt to implement an interim (between
> acpi 1.0b and 2.0) FADT acpi section we use to support ACPI reboot.  It does 
not
> appear that your bios vendor did it the same way we expect.  Since there is 
not
> really one true standard that I can find I can't say for SURE it is the bios 
who
> is wrong.  I would suggest either just ignoring this message or talk to your
> bios vendor asking them why their table size is only 129 bytes long when it
> should be 132 bytes.
> As of right now I do not believe this is a linux bug and as long as your 
system
> is rebooting ok you can just ignore it.  If you get more information from your
> bios vendor I would love to hear it.

Comment 8 Eric Paris 2006-10-11 15:38:06 EDT
Since the only people who can explain why their BIOS is 129 bytes long and what
they are doing with that extra byte is intel I'm going to close this as 'not a
bug'    We expect 4 bytes of information for the interim implementation of acpi
reboot but in this case we are not getting those 4 bytes.  As long as your
machine is rebooting properly I see no bug on our end.  You can safely ignore
the message or try to get intel to tell you why their bios is an illegal length.

Note You need to log in before you can comment on or make changes to this bug.