Bug 202354 - control-center %post script errors make for a noisy but incorrect installation
control-center %post script errors make for a noisy but incorrect installation
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-13 12:04 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-13 17:09:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-08-13 12:04:48 EDT
Description of problem:

As a result of typos in a %post script one gets during an installation

(many lines skipped)
.....
Attached schema
`/schemas/apps/gnome_settings_daemon/power_manager/start_power_manager' to key
`/apps/gnome_settings_daemon/power_manager/start_power_manager'
Installed schema
`/schemas/apps/gnome_settings_daemon/power_manager/start_power_manager' for
locale `C'
I/O warning : failed to load external entity " "
Failed to open ` ': No such file or directory

This is a result of a trailing blank on a line

   /etc/gconf/schemas/apps_gnome_settings_daemon_power_manager.schemas \ 

Also instead of 

   /etc/gconf/schemas/fontilus.schemas themus.schemas >& /dev/null

it should be there
   /etc/gconf/schemas/fontilus.schemas \
   /etc/gconf/schemas/themus.schemas >& /dev/null

Actually postuninstall script is even in a worse shape.  There are trailing
blanks all over the place, making intended continuation lines ineffective,
and a bare "themus.schemas" instead of a full path is also there.

Version-Release number of selected component (if applicable):
control-center-2.15.91-1.fc6
Comment 1 Michal Jaegermann 2006-08-13 12:41:40 EDT
Looking closer "a worse shape" for postuninstall script is not
correct.  It is really the same as for %post.  A trailing blank
where it should not be one and missing path to themus.schemas.
Comment 2 Ray Strode [halfline] 2006-08-13 12:42:38 EDT
What version of control-center? I'm not seeing this in the cvs spec file...

(Maybe it already got fixed?)
Comment 3 Ray Strode [halfline] 2006-08-13 13:18:33 EDT
Oh, it looks like Matthias already fixed it:
+* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.01-2.fc6
+- fix spec file (pointed out by Yanko Kaneti)
+
Comment 4 Michal Jaegermann 2006-08-13 13:54:16 EDT
> What version of control-center?

OK. Again:

> Version-Release number of selected component (if applicable):
> control-center-2.15.91-1.fc6

This is what showed up in the latest rawhide.

> Oh, it looks like Matthias already fixed it

Hm, something seems to be out of sync somehwere.  Here is what
'rpm -q --changelog control-center' has to say:

* Sun Aug 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.90-1.fc6
- Update to 2.15.91

* Mon Aug 07 2006 Karsten Hopp <karsten@redhat.com> 2.15.90-4
- add fix for new libebook api
......

Yes, I realize that versions on the right hand side are going backwards.

Unless "2.15.01-2.fc6" in what you quote was really supposed to
be "2.15.91-2.fc6"?  Could somebody please to check?

Comment 5 Matthias Clasen 2006-08-13 17:09:46 EDT
typo in the changelog version number, will be fixed in the next build

Note You need to log in before you can comment on or make changes to this bug.