Bug 202358 - e2fsprogs bug: offline file system resize
e2fsprogs bug: offline file system resize
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-13 12:48 EDT by Ivan Krastev
Modified: 2015-01-07 19:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:41:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Krastev 2006-08-13 12:48:51 EDT
Description of problem:
resize2fs give me error after offline filesystem expand.
Error is: resize2fs: Filesystem has unsupported feature(s)

This is the fs features:
dumpe2fs 1.32 (09-Nov-2002)
Filesystem features:      has_journal filetype sparse_super large_file


Version-Release number of selected component (if applicable):
e2fsprogs-1.32-15.3

How reproducible:
error after using e2fsadm utility

Steps to Reproduce:
1. Create new PV - fsck, pvcreate
2. Add PV to existing volume group - vgextend
3. Umount fs - umount
4. Extend fs - "e2fsadm -L +84G ... "
  
Actual results:
no fs change - same 900G volume

Expected results:
new 1T volume

Additional info: disk used for LVM are from SAN storage
Comment 1 Ivan Krastev 2006-08-13 12:51:48 EDT
forgot this one -> kernel is : 2.4.21-40.ELsmp
Comment 2 Thomas Woerner 2006-08-15 08:46:34 EDT
Please post the output of pvdisplay and vgdisplay?
Comment 3 Ivan Krastev 2006-08-15 09:01:31 EDT
I found the problem is with shared disks, who are mounted in 2 different
servers. In one of servers new disk is part of LV, but in another is missing. In
both servers disk is part of VG. After extending LV on second server I will post
results.
Comment 6 RHEL Product and Program Management 2007-10-19 14:41:52 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.