Bug 202407 - sniff and dogtail-recorder can't work
sniff and dogtail-recorder can't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dogtail (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Zack Cerza
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 04:24 EDT by Yan Tian
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-17 23:12:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Tian 2006-08-14 04:24:53 EDT
Description of problem:
sniff and dogtail-recorder can't work in RHEL5-Client-20060810.0(i386)
Workstation system.

Version-Release number of selected component (if applicable):
dogtail-0.5.2-1.fc6

How reproducible:
8 in 10 times

Steps to Reproduce:
1.run sniff
2.run dogtail-recorder
3.view version of pyspi
  
Actual results:
1.[root@dhcp-0-178 ~]# sniff
Detecting distribution: Red Hat/Fedora/derived distribution
Traceback (most recent call last):
  File "/usr/bin/sniff", line 7, in ?     from dogtail import tree
  File "/usr/lib/python2.4/site-packages/dogtail/tree.py", line 1239, in ?
    children = root.children
  File "/usr/lib/python2.4/site-packages/dogtail/tree.py", line 461, in
__getattr__     a = self.__accessible.getChildAtIndex (i)
  File "pyspi.pyx", line 497, in atspi.Accessible.getChildAtIndex
  File "pyspi.pyx", line 116, in atspi.exception_handler
atspi.SpiException: Non-fatal SPIException: type:0 source:0
"IDL:omg.org/CORBA/COMM_FAILURE:1.0"

2.[root@dhcp-0-178 ~]# dogtail-recorder
GTK Accessibility Module initialized
Detecting distribution: Red Hat/Fedora/derived distribution
Traceback (most recent call last):
  File "/usr/bin/dogtail-recorder", line 217, in ?
    import dogtail.tree
  File "/usr/lib/python2.4/site-packages/dogtail/tree.py", line 1239, in ?
    children = root.children
  File "/usr/lib/python2.4/site-packages/dogtail/tree.py", line 461, in __getattr__
    a = self.__accessible.getChildAtIndex (i)
  File "pyspi.pyx", line 497, in atspi.Accessible.getChildAtIndex
  File "pyspi.pyx", line 116, in atspi.exception_handler
atspi.SpiException: Non-fatal SPIException: type:0 source:0
"IDL:omg.org/CORBA/COMM_FAILURE:1.0"
application finalize called

3.[root@dhcp-0-178 ~]# rpm -q pyspi
pyspi-0.5.5-1.fc6

Expected results:
sniff and dogtail-recorder can work normally.

Additional info:
Comment 1 Yan Tian 2006-08-15 04:24:27 EDT
Same bug in x86_64 hardware

Description of problem:
sniff and dogtail-recorder can't work in RHEL5-Client-20060810.0(x86_64)
Workstation system.

Version-Release number of selected component (if applicable):
dogtail-0.5.2-1.fc6

How reproducible:
always

Steps to Reproduce:
1.run sniff
2.run dogtail-recorder
  
Actual results:
1.[root@dhcp-0-178 ~]# sniff
Detecting distribution: Red Hat/Fedora/derived distribution
Creating /tmp/dogtail ...
Creating /tmp/dogtail/logs ...
Creating /tmp/dogtail/data ...

2.[root@dhcp-0-178 ~]# dogtail-recorder
GTK Accessibility Module initialized
Detecting distribution: Red Hat/Fedora/derived distribution

__'ctrl+c' can't stop above process.

Expected results:
sniff and dogtail-recorder can work normally.

Additional info:
Comment 2 Zack Cerza 2006-08-18 14:07:37 EDT
I suspect this isn't dogtail's fault but some other application running
providing some very corrupt data to the AT-SPI. What applications are running
when you encounter this problem?
Comment 3 Yan Tian 2006-08-20 21:23:04 EDT
I tested this problem in clean system of RHEL5-Client-20060810.0 Workstation. I
will test in RHEL5-Client-20060818.3 system to verify this bug.
Comment 4 Zack Cerza 2006-08-21 16:37:59 EDT
I'm seeing the problem, too. Broken applications are making the CORBA layer
fail. In older versions of dogtail it usually wouldn't take dogtail down. CCing
Dave Malcolm.
Comment 5 Yan Tian 2006-08-21 21:15:38 EDT
Same problem in RHEL5-Client-20060818.3(i386) desktop system.
Comment 6 Zack Cerza 2006-08-23 12:56:42 EDT
I'm thinking the solution might be to have dogtail ignore the SpiException if
and only if it encounters it while looking for children of the root (desktop)
node. That way broken applications wouldn't show up in dogtail until you
specifically tried to access them, at which time dogtail would fail. But then
we'd know which apps were broken.
Comment 7 Zack Cerza 2006-08-24 12:45:07 EDT
While I was able to reproduce this bug earlier, after a yum update today I am no
longer able to reproduce. Are you still seeing the problem after updating to the
latest packages?
Comment 8 Yan Tian 2006-08-25 02:42:18 EDT
After a yum today my test machine still reproduced the same bug. But in other 2
test machines of my colleagues the problem didn't reproduce.

I can't confirm whether hardware compatibility caused this bug in my test
machine. Because this machine often crashes suddenly. Nicole reported this bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=203877.
Comment 9 Yan Tian 2006-09-11 05:46:46 EDT
Today I installed RHEL5-Client-Beta1 Desktop System. Sniff worked normally. But
dogtail-recorder still couldn't work.

Version-Release number of selected component (if applicable):
dogtail-0.5.2-1.fc6

How reproducible:
always

Steps to Reproduce:
1.run dogtail-recorder
2.Click 'Record' button
3.Click 'Show script' to view the code
4.Click 'Input Text' button
5.Show dialog 'Recorder' which tip 'First click where you want to input
text...', 'OK' button is unenabled.
6.Click the edit areas of 'gedit'(try click and double click)
7.'OK' button of 'Recorder dailog' is still unenabled
8.No automatic script produced in 'Show script' area with arbitrary actions
  
Actual results:
After clicking input text area of application, 'OK' button of 'Recorder dialog'
 was always unenabled.
'Show script' area didn't record automaticly code of user actions.

Expected results:
After clicking input text area of application, 'OK' button of 'Recorder dialog'
should be enabled, then input the text.
'Show script' area should record automaticly code of user actions.
Comment 10 Yan Tian 2006-09-13 03:32:22 EDT
In RHEL5-Client-Beta1 Desktop System, got code from CVS. After 'make rpm' got
binary package dogtail-0.5.3-1.noarch.rpm. Then 'rpm -U dogtail-0.5.3-1.noarch.rpm'.

dogtail-recorder run error as below:

[root@dhcp-0-158 dist]# dogtail-recorder
Detecting distribution: Red Hat/Fedora/derived distribution
GTK Accessibility Module initialized
Traceback (most recent call last):
  File "/usr/bin/dogtail-recorder", line 447, in ?
    class EventRecorder:
  File "/usr/bin/dogtail-recorder", line 451, in EventRecorder
    modifiers = {
AttributeError: 'module' object has no attribute 'Accessibility_MODIFIER_NUMLOCK'
application finalize called
Comment 11 Zack Cerza 2006-09-13 12:24:31 EDT
dogtail CVS needes pyspi CVS; sorry for the confusion. dogtail CVS will now fail
to install if pyspi is not new enough.
Comment 12 Zack Cerza 2006-09-14 16:51:17 EDT
I built new dogtail and pyspi packages last night that should fix this.
Comment 13 Yan Tian 2006-09-18 03:40:43 EDT
test in RHEL5-Client-20060915.0(i386) Workstation system:
1.rpm -q pyspi dogtail
pyspi-0.5.5-1.fc6
dogtail-0.5.2-3.fc6
sniff and dogtail-recorder can't still work.

2.get source code from CVS, compile for getting binary package, update new
version package
  pyspi-0.6.0-1
  dogtail-0.6.0-1
sniff and dogtail-recorder can work.
Comment 14 Yan Tian 2006-10-17 22:33:42 EDT
Verified it has been fixed in RHEL5-Client-20061012.9 system.
Comment 15 Yan Tian 2006-10-17 23:12:30 EDT
Verified in pyspi-0.6.0-2.fc6, dogtail-0.6.0-1.fc6.

Note You need to log in before you can comment on or make changes to this bug.