Bug 202435 - Email address claims to update but continues to use original address
Email address claims to update but continues to use original address
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Beth Nackashi
https://rhn.redhat.com/rhn/account/Ch...
:
Depends On:
Blocks: 201770
  Show dependency treegraph
 
Reported: 2006-08-14 09:44 EDT by Robert Locke
Modified: 2007-04-18 13:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhn414
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 10:50:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Locke 2006-08-14 09:44:51 EDT
Description of problem:

I have had a login via GLS sending emails to my personal email address (as I was
a contractor).  Went to https://rhn.redhat.com/rhn/account/ChangeEmail.do to
change my email to my new "internal" email address since I was recently hired by
GLS.  Page claims that it will send a confirmation email - never received one. 
Page claims to use the new email.  All alerts, etc. continue to be sent to the
original personal email address.

Version-Release number of selected component (if applicable):
Bottom of page says RHN 4.1.0

How reproducible:
Have tried changing it to other alternate personal email addresses.  While the
"page" reflects whatever I have changed it to, all emails continue to use the
original email address.

Steps to Reproduce:
1. Go to Your Account - Change Email
2. Fill in new email address
3. Click Update
  
Actual results:
Email address appears to be changed in database, but emails continue to be sent
to old email address.

Expected results:
All emails should be sent to the new email address

Additional info:
Have also tried turning off emails for an hour and then turning them back on via
the "Your Preferences" link thinking it might unsubscribe the old/subscribe the
new.  Had no effect.
Comment 1 Jesus M. Rodriguez 2006-08-31 21:34:15 EDT
Changed query to look at the new canonical source for email which is
web_user_personal_info.
Comment 3 Jesus M. Rodriguez 2006-09-05 14:45:58 EDT
TEST PLAN
------------
1) creae a user and make sure you get emails via taskomatic, i.e. for errata
updates.
2) change your email address
3) confirm emalis go to new email address

NOTE: removed verification verbiage, so no email verification will occur.
Comment 4 Beth Nackashi 2006-09-07 17:55:57 EDT
Verified on satellite with taskomatic-4.1.0-820.
Comment 5 Beth Nackashi 2006-09-20 10:50:13 EDT
closing -- current release.  RHN414 phase 14 gazillion is now in production.

Note You need to log in before you can comment on or make changes to this bug.