Bug 202477 - Component: Software Manager Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType' object has no attribute 'add_option' Traceback (most recent call last): File "/usr/sbin/pirut", line 363, in ? main() File "/usr/sb...
Component: Software Manager Summary: TB9275b279 downloadonly.py:26:config_ho...
Status: CLOSED DUPLICATE of bug 191630
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 14:44 EDT by keith lawford
Modified: 2014-01-21 17:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 20:38:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Component: Software Manager Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType' object has no attribute 'add_option' Traceback (most recent call last): File "/usr/sbin/pir (1.17 KB, application/octet-stream)
2006-08-14 14:44 EDT, keith lawford
no flags Details

  None (edit)
Description keith lawford 2006-08-14 14:44:51 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 keith lawford 2006-08-14 14:44:52 EDT
Created attachment 134158 [details]
Component: Software Manager
Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType' object has no attribute 'add_option'

Traceback (most recent call last):
  File "/usr/sbin/pir

Traceback (most recent call last):
  File "/usr/sbin/pir
Comment 2 Jeremy Katz 2006-08-14 20:38:12 EDT

*** This bug has been marked as a duplicate of 191630 ***
Comment 3 keith lawford 2008-08-02 16:16:37 EDT
The original summary for this bug was longer than 255 characters, and so it was truncated when Bugzilla was upgraded. The original summary was:

Component: Software Manager  Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType' object has no attribute 'add_option'    Traceback (most recent call last):    File "/usr/sbin/pirut", line 363, in ?      main()    File "/usr/sbin/pirut", line 358, in main      pm = PackageManager()    File "/usr/sbin/pirut", line 56, in __init__      GraphicalYumBase.__init__(self, False)    File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 123, in __init__      self.doPluginSetup(types=(yum.plugins.TYPE_CORE))    File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 173, in doPluginSetup      optparser, types)    File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 148, in __init__      self.run('config')    File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run      func(conduitcls(self, self.base, conf, **kwargs))    File "/usr/lib/yum-plugins/downloadonly.py", line 26, in config_hook      parser.add_option('', '--downloadonly', dest='dlonly', action='store_true',  AttributeError: 'NoneType' object has no attribute 'add_option'    Local variables in innermost frame:  conduit: <yum.plugins.ConfigPluginConduit instance at 0x2b155d594680>  parser: None

Note You need to log in before you can comment on or make changes to this bug.