Bug 202505 - pipe to nonexistent program causes ksh to get SIGSTOP and hang forever
Summary: pipe to nonexistent program causes ksh to get SIGSTOP and hang forever
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ksh   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-14 20:45 UTC by Todd Allen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-18 09:43:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Todd Allen 2006-08-14 20:45:00 UTC
Description of problem:
If you have "." on the beginning of your PATH, and then you issue a command with
a pipe where the last process on the pipe is the name of a nonexistent program,
the ksh will get a SIGSTOP, and then drop into the background.  If you attempt
to resume with the fg command, it will be stopped with another SIGSTOP, ad
infinitum.

If your ksh was started under an xterm or gnome-terminal instead of under
something where dropping into the background is convenient, the xterm or
gnome-terminal will just exit when the ksh drops into the background.

Usually this happens if I typo a command in the ksh.  Having the ksh go AWOL
isn't a very nice response to that.  :)

Version-Release number of selected component (if applicable):
ksh-20060124-3

How reproducible:
Always

Steps to Reproduce:
# These executed as root:
1. useradd jojo
2. chsh jojo & specify: /bin/ksh
3. su - jojo
# These executed as the new jojo user:
4. export PATH=".:${PATH}"
5. echo it | bogus

Actual results:
-ksh: bogus: not found [No such file or directory]
[1] + Stopped (SIGSTOP)        su - jojo

Expected results:
-ksh: bogus: not found [No such file or directory]

Additional info:
If you then do this:
6. fg
It will respond with this:
su - jojo
[1] + Stopped (SIGSTOP)        su - jojo

Comment 1 Fedora Update System 2006-08-17 14:58:50 UTC
ksh-20060214-1.fc5.1 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 2 Todd Allen 2006-08-17 16:10:08 UTC
It looks like the bug is fixed in 200602014.  Thanks.



Note You need to log in before you can comment on or make changes to this bug.