Bug 202516 - Problem with /net
Problem with /net
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
: Reopened
: 223942 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 17:38 EDT by Adam Huffman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: autofs-5.0.1-0.rc3.20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-15 20:15:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
autofs running with --debug (19.59 KB, application/octet-stream)
2006-09-20 17:28 EDT, Adam Huffman
no flags Details

  None (edit)
Description Adam Huffman 2006-08-14 17:38:31 EDT
Description of problem:
The auto.net map does not appear to be working on my rawhide (was FC6 test 2)
installation.

Version-Release number of selected component (if applicable):
5.0.1-0.rc1.14

How reproducible:
Every time

Steps to Reproduce:
1. cd /net/<local nfs share>
2.
3.
  
Actual results:
No such file or directory message in shell

Expected results:
Local NFS share is mounted by autofs

Additional info:

Before I commented out the +auto-master part of the autofs config file, I got
the following error:
Aug 14 22:38:58 vaio automount[15766]: lookup_read_master: lookup(nisplus):
couldn't locat nis+ table auto.maste
r
Aug 14 22:38:58 vaio automount[15766]: lookup_read_master: lookup(file): failed
to read included master map auto
.master

After commenting that out, I get this error when attempting to use an NFS automount:

Aug 14 22:41:42 vaio automount[15818]: attempting to mount entry /net/192.168.0.10
Aug 14 22:41:42 vaio automount[15818]: parse_mapent: parse(sun): invalid location
Comment 1 Ian Kent 2006-08-15 07:07:43 EDT
Thanks.
I'll investigate.
Comment 2 Ian Kent 2006-08-16 03:35:19 EDT
(In reply to comment #0)
> Additional info:
> 
> Before I commented out the +auto-master part of the autofs config file, I got
> the following error:
> Aug 14 22:38:58 vaio automount[15766]: lookup_read_master: lookup(nisplus):
> couldn't locat nis+ table auto.maste
> r
> Aug 14 22:38:58 vaio automount[15766]: lookup_read_master: lookup(file): failed
> to read included master map auto
> .master

This is normal as nisplus is listed as a source in nsswitch.conf
and you probably don't such a map. If the sources listed in nsswitch
are not being used possibly they could be removed.

> 
> After commenting that out, I get this error when attempting to use an NFS
automount:
> 
> Aug 14 22:41:42 vaio automount[15818]: attempting to mount entry /net/192.168.0.10

Yes.
This is fixed in autofs-5.0.1-0.rc1.15.
Please let me know if this works for you.

Ian
Comment 3 Adam Huffman 2006-08-16 10:49:14 EDT
Yes, I can confirm that the newer version fixes this problem.  Thanks for the
quick response.
Comment 4 Adam Huffman 2006-09-20 17:25:14 EDT
This seems to have cropped up again - if you'd prefer me to open a separate bug,
please let me know.
Comment 5 Adam Huffman 2006-09-20 17:26:28 EDT
autofs-5.0.1-0.rc2.1
Comment 6 Adam Huffman 2006-09-20 17:28:30 EDT
Created attachment 136784 [details]
autofs running with --debug
Comment 7 Ian Kent 2006-09-20 23:11:43 EDT
(In reply to comment #4)
> This seems to have cropped up again - if you'd prefer me to open a separate bug,
> please let me know.

Please see 205038 for more info on this.

I think you need nfs-utils-1.0.9-7.

Ian
Comment 8 Adam Huffman 2006-09-21 03:33:52 EDT
I'm not authorized to see that bug.  However, I'll give that package a try.
Comment 9 Andy Shevchenko 2007-01-23 01:38:53 EST
*** Bug 223942 has been marked as a duplicate of this bug. ***
Comment 10 Andy Shevchenko 2007-01-23 01:40:34 EST
In reply to comment #7:
The nfs-utils is high than 1.0.9, but issue stil present.
Please, see comments in the bug #223942.
Comment 11 Ian Kent 2007-01-23 03:01:48 EST
(In reply to comment #10)
> In reply to comment #7:
> The nfs-utils is high than 1.0.9, but issue stil present.
> Please, see comments in the bug #223942.
> 

This doesn't appear to be a problem for me.
You'll need to post a debug log.
See http://people.redhat.com/jmoyer for directions.

Ian
Comment 12 Ian Kent 2007-02-14 00:34:07 EST
(In reply to comment #11)
> (In reply to comment #10)
> > In reply to comment #7:
> > The nfs-utils is high than 1.0.9, but issue stil present.
> > Please, see comments in the bug #223942.
> > 
> 
> This doesn't appear to be a problem for me.
> You'll need to post a debug log.
> See http://people.redhat.com/jmoyer for directions.

Is this still a problem with the latest updates?

Ian

Comment 13 Andy Shevchenko 2007-02-15 09:41:35 EST
My minor tests show no bug on the recent FC6 autofs.
If the issue will be occured I reopen the bug #223942.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.