Bug 202585 - Non-SDK features cannot be enabled or disabled
Non-SDK features cannot be enabled or disabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 07:10 EDT by Mykola Ulianytskyi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.2.1-23.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 13:29:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mykola Ulianytskyi 2006-08-15 07:10:07 EDT
Description of problem:
PyDev doesn't work

Version-Release number of selected component (if applicable):
eclipse-pydev-0.9.3_fc-17
eclipse-platform-3.2.0-1jpp_10fc

How reproducible:

Steps to Reproduce:
1. Help -> Software Updates -> Manage configuration
2. PyDev for Eclipse 0.9.3 -> Enable

Actual results:


Expected results:
Current configuration contains errors that are not corrected by the requested
operation and more errors would be introduced. See details for more information.
  ----- Current configuration problems -----
    Error creating feature
"file:/usr/share/eclipse/features/org.eclipse.rcp_-MeGG/".
[/usr/share/eclipse/features/org.eclipse.rcp_-MeGG/feature.xml (No such file or
directory)]
  ----- Configuration problems after the operation -----
    PyDev for Eclipse (0.9.3) The site is not updateable: file:/usr/share/eclipse/.
    Error creating feature
"file:/usr/share/eclipse/features/org.eclipse.rcp_-MeGG/".
[/usr/share/eclipse/features/org.eclipse.rcp_-MeGG/feature.xml (No such file or
directory)]

  

Additional info:
Comment 1 Ben Konrath 2006-09-04 16:10:19 EDT
Ok, there's definitely a problem here. The 'No such file or directory' problem
has been fixed but now when you try to enable a feature you get this message:

Requested operation cannot be performed because it would invalidate the current
configuration. See details for more information.
  PyDev for Eclipse (0.9.3) The site is not updateable: file:/usr/share/eclipse/.
Comment 2 Ben Konrath 2006-09-04 16:11:58 EDT
Changing component to eclipse because this happens with all non-SDK features.
Comment 3 Andrew Overholt 2006-10-05 15:51:08 EDT
Updating summary to more accurately reflect issue.
Comment 4 Ben Konrath 2006-12-06 13:29:47 EST
This is fixed FC-6 updates and rawhide.

Note You need to log in before you can comment on or make changes to this bug.