Bug 202605 - FC6 Rawhide failed to reboot into the vm guest
FC6 Rawhide failed to reboot into the vm guest
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 09:59 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 10:52:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 26284 None None None Never

  None (edit)
Description IBM Bug Proxy 2006-08-15 09:59:35 EDT
LTC Owner is: nivedita@us.ibm.com
LTC Originator is: markwiz@us.ibm.com


Problem description:
Installed a xen guest. Install over the network seemd to be fine. When the install
completed, the guest would not reboot. The guest console hung.
I then did a xm create vm1 and got the following messages


[root@dhcp59-190 ~]# xm create -c vm1
Using config file "/etc/xen/vm1".
Traceback (most recent call last):
  File "/usr/bin/pygrub", line 256, in ?
    cf = get_config(file, isconfig)
  File "/usr/bin/pygrub", line 130, in get_config
    raise RuntimeError, "we couldn't find /boot/grub{menu.lst,grub.conf}
" + \
RuntimeError: we couldn't find /boot/grub{menu.lst,grub.conf} in the
image provided. halt!
Error: Boot loader didn't return any data!
You have new mail in /var/spool/mail/root

this is blocker since I can not get into the guest.
Comment 1 Jeremy Katz 2006-08-15 10:03:28 EDT
Which tree is this with, what arch, etc?  We need a lot more details here.
Comment 2 IBM Bug Proxy 2006-08-15 16:01:38 EDT
----- Additional Comments From chavez@us.ibm.com (prefers email at lnx1138@us.ibm.com)  2006-08-15 16:09 EDT -------
This is for the i386 arch.

The tree was from
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/os/
from 8/11.

If you want I can try
porkchop.redhat.com/rel-eng/FC6-Test2-re20060803.1/5.91/i386/os 
Comment 3 Jeremy Katz 2006-08-15 16:04:21 EDT
Yes, test2 would be much better to try
Comment 4 IBM Bug Proxy 2006-08-15 16:22:17 EDT
------- Additional Comments From dbarrera@us.ibm.com  2006-08-15 16:30 EDT -------
(In reply to comment #13)
> ----- Additional Comments From katzj@redhat.com  2006-08-15 16:04 EST -------
> Yes, test2 would be much better to try
> 
> -- 

We had problems installing FC6 test2:
https://bugzilla.linux.ibm.com/show_bug.cgi?id=26171 
Comment 5 Jeremy Katz 2006-08-16 09:29:46 EDT
I can't see that bug :-)
Comment 6 IBM Bug Proxy 2006-08-16 09:51:38 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |FIXEDAWAITINGTEST
         Resolution|                            |FIX_BY_DISTRO




------- Additional Comments From markwiz@us.ibm.com  2006-08-16 09:59 EDT -------
Ran with the /rel-eng/FC6-Test2-re20060803.1/5.91/i386 and it worked. I will
close this as being fixed by distro. 

Note You need to log in before you can comment on or make changes to this bug.