Bug 20261 - Mounting file systems
Mounting file systems
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-02 18:54 EST by Need Real Name
Modified: 2014-03-16 22:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-12 16:23:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-02 18:54:29 EST
When rc.sysinit mounts local and other filesystems, it doesn't take any
notice of whether they are mounted already.
As an example, I run devfs and mount /dev at the very start of rc.sysinit.
When rc.sysinit gets to the point of mounting all the filesystems in
/etc/inittab it tries to mount this one as well, but obviously it generates
errors because it's already mounted.
Obviously this isn't a direct bug because RedHat don't ship with devfs
enabled, but it is a minor annoyance that some rc.sysinit scripting magic
could easily cure.
Comment 1 Bill Nottingham 2000-12-12 03:10:53 EST
mount -a shouldn't error for things already mounted.

What does your:

a) /proc/mounts
b) /etc/fstab
c) error message

look like?
Comment 2 Need Real Name 2000-12-12 16:23:53 EST
-(cmsj@tenshu)-(~)- cat /proc/mounts
/dev/ide/host0/bus0/target0/lun0/part3 / ext2 rw 0 0
none /dev devfs rw 0 0
/proc /proc proc rw 0 0
/dev/hda1 /mnt/win-c vfat rw 0 0
/dev/sdb2 /home ext2 rw,nosuid 0 0
/dev/sdb4 /opt ext2 rw,nosuid 0 0
/dev/sdc1 /opt/leech ext2 rw,nosuid 0 0
none /dev/pts devpts rw 0 0
shm /var/shm shm rw 0 0
/dev/sdb3 /opt/mp3 ext2 rw,nosuid 0 0

-(cmsj@tenshu)-(~)- cat /etc/fstab
/dev/hda3       /               ext2    defaults                        1 1
/dev/hda1       /mnt/win-c      vfat    defaults                        0 0
/dev/hda2       swap            swap    pri=2                           0 0
/swap           swap            swap    pri=1                           0 0
/dev/sdb2       /home           ext2    nosuid                          1 2
/dev/sdb3       /opt/mp3        ext2    nosuid                          1 2
/dev/sdb4       /opt            ext2    nosuid                          1 2
/dev/sdc1       /opt/leech      ext2    nosuid                          1 2
/dev/sda4       /mnt/zip        auto    noauto,user,exec,dev,suid       0 0
/dev/fd0        /mnt/floppy     auto    owner,noauto                    0 0
/dev/sr0        /mnt/cdrom      iso9660 noauto,ro,user,exec,dev,nosuid  0 0
/dev/sr1        /mnt/cdr        iso9660 noauto,ro,user,exec,dev,nosuid  0 0
none            /proc           proc    defaults                        0 0
none            /dev            devfs   defaults                        0 0
none            /proc/bus/usb   usbdevfs  mode=660,noauto               0 0
none            /dev/pts        devpts  gid=5,mode=620                  0 0
shm             /var/shm        shm     defaults                        0 0

as for the error message:

-(root@tenshu)-(/home/cmsj)- mount -a
mount: none already mounted or /dev busy
mount: according to mtab, none is mounted on /proc
Comment 3 Bill Nottingham 2001-01-29 17:31:27 EST
Will be fixed in 5.60-1 - thanks!
Comment 4 Chun-Chung Chen 2001-04-07 07:52:46 EDT
Unfortunately, when devfs entry is added to mtab, the halt script will try to
umount it when the system is shutting down. Because devfs is always busy, this
will always gives an error message. Probably should add a "nodevfs" to the halt
script, too.

Note You need to log in before you can comment on or make changes to this bug.