Bug 202630 - Latest autofs update breaks nis automounts
Summary: Latest autofs update breaks nis automounts
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs   
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jeff Moyer
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-15 16:20 UTC by Greg Bridges
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-07 16:54:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
As requested, my nsswitch.conf (1.68 KB, text/plain)
2006-08-15 20:10 UTC, Greg Bridges
no flags Details
The auto.master from the nis server (448 bytes, text/plain)
2006-08-15 20:14 UTC, Greg Bridges
no flags Details
requested autofs file (824 bytes, text/plain)
2006-09-06 21:03 UTC, Greg Bridges
no flags Details

Description Greg Bridges 2006-08-15 16:20:48 UTC
Description of problem:
Our nis server has numerous nis mounts available on the server. They have been
available and working for three years. When I got the quarterly updates
(autofs-4.1.3-187:1.i386 ) from the rhn yesterday, my automounts immediately
quit working. When I rolled back to autofs-4.1.3-169, it began working again.
The error messages on the client were:

Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.ptah
Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.karnak
Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.djoser
Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.luxor
Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.stroustroup
Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.mamacass

The maps referenced are on the nis server.

Comment 1 Jeff Moyer 2006-08-15 16:36:38 UTC
Please attach your master map and your /etc/nsswitch.conf

Comment 2 Greg Bridges 2006-08-15 20:10:33 UTC
Created attachment 134256 [details]
As requested, my nsswitch.conf

Comment 3 Greg Bridges 2006-08-15 20:14:18 UTC
Created attachment 134258 [details]
The auto.master from the nis server

Comment 4 Greg Bridges 2006-08-15 20:23:19 UTC
I should note that the nis server is running on RHE ES3, update 8. 

Comment 5 Brandon Kitchen 2006-08-22 17:20:03 UTC
This bug is also affecting my company. We are using Solaris machines for NIS
servers though.

Again, as the previous poster mentioned, rolling back to the previous version of
autofs fixed the problem. I believe the problem is due to changes in the
/etc/init.d/autofs init script.

Comment 6 Mike 2006-08-30 20:40:59 UTC
We are also affected by this bug in autofs-4.1.3-187.  We are seeing the same
symptoms and simply using the autofs init script from autofs-4.1.3-169 seems to
fix this issue.

Comment 7 Jeff Moyer 2006-09-06 16:36:37 UTC
(In reply to comment #0)
> Description of problem:
> Our nis server has numerous nis mounts available on the server. They have been
> available and working for three years. When I got the quarterly updates
> (autofs-4.1.3-187:1.i386 ) from the rhn yesterday, my automounts immediately
> quit working. When I rolled back to autofs-4.1.3-169, it began working again.
> The error messages on the client were:
> 
> Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.ptah
> Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.karnak
> Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.djoser
> Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.luxor
> Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.stroustroup
> Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.mamacass
> 
> The maps referenced are on the nis server.


You master map points directly to /etc/auto.*, so I'm a little confused.  Are
you saying that you want the automounter to retrieve auto.luxor et. al. from the
nis server?  Do you have a /etc/auto.master map?  If so, please upload the
contents of that.  Also, it would be helpful if you could include your
/etc/sysconfig/autofs file.

Thanks!

Comment 8 Greg Bridges 2006-09-06 21:03:31 UTC
Created attachment 135696 [details]
requested autofs file

Comment 9 Greg Bridges 2006-09-06 21:04:37 UTC
(In reply to comment #7)
> (In reply to comment #0)
> > Description of problem:
> > Our nis server has numerous nis mounts available on the server. They have been
> > available and working for three years. When I got the quarterly updates
> > (autofs-4.1.3-187:1.i386 ) from the rhn yesterday, my automounts immediately
> > quit working. When I rolled back to autofs-4.1.3-169, it began working again.
> > The error messages on the client were:
> > 
> > Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.ptah
> > Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.karnak
> > Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.djoser
> > Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.luxor
> > Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map
/etc/auto.stroustroup
> > Aug 15 10:59:09 ambler nsswitch: nsswitch: couldn't find map /etc/auto.mamacass
> > 
> > The maps referenced are on the nis server.
> 
> 
> You master map points directly to /etc/auto.*, so I'm a little confused.  Are
> you saying that you want the automounter to retrieve auto.luxor et. al. from the
> nis server?  Do you have a /etc/auto.master map?  If so, please upload the
> contents of that.  Also, it would be helpful if you could include your
> /etc/sysconfig/autofs file.
> 
> Thanks!

Honestly, I set this up three or four years ago and I've never had to touch it
again. I don't remember why the auto.master is set up that way on the server (I
probably used a howto). I assume that the nsswitch was not attempting to find
the auto.* maps before.

The auto.master on my client machine has no uncommented lines. I will attach my
autofs file as requested.

Thanks,
Greg

Comment 10 Jeff Moyer 2006-09-07 16:29:38 UTC
I still don't have a clear picture of what is going on.  Do the file maps
/etc/auto.djoser, /etc/auto.ptah, /etc/auto.karnak, /etc/auto.luxor,
/etc/auto.stroustroup and /etc/auto.mamacass exist on the client?

If not, this sounds like a configuration error.  Change your nis auto.master to
remove the "/etc/" part of each of the map names, and all should work as you expect.

If I'm way off base, then please send along the output from "sh -x
/etc/init.d/autofs start" for both the old version and the new version of the
automounter.

Thanks.

Comment 11 Greg Bridges 2006-09-07 16:47:35 UTC
(In reply to comment #10)
> I still don't have a clear picture of what is going on.  Do the file maps
> /etc/auto.djoser, /etc/auto.ptah, /etc/auto.karnak, /etc/auto.luxor,
> /etc/auto.stroustroup and /etc/auto.mamacass exist on the client?
> 
No

> If not, this sounds like a configuration error.  Change your nis auto.master to
> remove the "/etc/" part of each of the map names, and all should work as you
expect.

That fixed my problem. I verified that it works with both the old autofs and the
new autofs. 

Thanks for your help,
Greg


Comment 12 Jeff Moyer 2006-09-07 16:54:49 UTC
Great.  It's strange that it ever worked!  ;)


Note You need to log in before you can comment on or make changes to this bug.