Bug 202649 - kernel BUG at fs/ext3/namei.c:383
kernel BUG at fs/ext3/namei.c:383
Status: CLOSED DUPLICATE of bug 202648
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 14:11 EDT by Scott Kennedy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-18 11:11:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Kennedy 2006-08-15 14:11:32 EDT
Description of problem:
When trying to update system to newest devel using yum.  I get the following
error in dmesg and the update stops, however the system is responsive:

kernel BUG at fs/ext3/namei.c:383!
invalid opcode: 0000 [#1]
SMP 
last sysfs file: /block/hda/hda1/size
Modules linked in: autofs4 ip_conntrack_netbios_ns ipt_REJECT xt_state
ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables nls_utf8 ntfs
video button battery ac radeon drm ipv6 parport_pc lp parport nvram
snd_intel8x0m snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq joydev snd_seq_device snd_pcm_oss snd_mixer_oss
snd_pcm ohci1394 8139too snd_timer i2c_i801 snd ehci_hcd uhci_hcd i2c_core
8139cp ieee1394 soundcore mii snd_page_alloc dm_snapshot dm_zero dm_mirror
dm_mod ext3 jbd
CPU:    0
EIP:    0060:[<e08c80d6>]    Not tainted VLI
EFLAGS: 00010292   (2.6.15-1.2032_FC5.biogodsmp #1) 
EIP is at dx_probe+0x16e/0x2c0 [ext3]
eax: 00000081   ebx: da5d1b1c   ecx: ce6c1ce8   edx: e08d2b52
esi: d5329418   edi: 00000000   ebp: ddbfba0c   esp: ce6c1ce4
ds: 007b   es: 007b   ss: 0068
Process yum (pid: 2130, threadinfo=ce6c1000 task=dfa8d9b0)
Stack: <0>e08d2b52 e08d1ba8 e08d2b42 0000017f e08d2cd8 c1362810 00200006 da5d1b1c 
       c0360e00 9a8273d8 ce6c1d4c dfc4703c da5d1b1c d320e1c0 da5d1b9c e08c8ac1 
       ce6c1d9c ce6c1dc4 ce6c1de0 d320e1c0 dfc4703c dd164d4c dcd7d30c da23ad4c 
Call Trace:
 [<e08c8ac1>] ext3_find_entry+0xc1/0x53b [ext3]     [<c0165d09>] __getblk+0x3d/0x23d
 [<c016045d>] cache_alloc_debugcheck_after+0xc1/0xf9     [<c0178157>]
d_alloc+0x1d/0x1c1
 [<c0160514>] kmem_cache_alloc+0x7f/0x89     [<c0178157>] d_alloc+0x1d/0x1c1
 [<e08ca256>] ext3_lookup+0x21/0x77 [ext3]     [<c016fb54>] do_lookup+0xb2/0x14d
 [<c01716c2>] __link_path_walk+0x834/0xc7d     [<c013466c>]
autoremove_wake_function+0xd/0x2d
 [<c0171b54>] link_path_walk+0x49/0xbd     [<c01458ae>]
audit_syscall_exit+0x267/0x322
 [<c0171eef>] do_path_lookup+0x1e3/0x248     [<c0172649>] __user_walk_fd+0x29/0x3a
 [<c016c458>] vfs_stat_fd+0x15/0x3c     [<c01458ae>] audit_syscall_exit+0x267/0x322
 [<c016c50c>] sys_stat64+0xf/0x23     [<c0106ace>] do_syscall_trace+0x104/0x14a
 [<c0103d81>] syscall_call+0x7/0xb    <0>Code: 0c 29 d0 83 e8 18 c1 e8 03 39 c1
74 29 68 d8 2c 8d e0 68 7f 01 00 00 68 42 2b 8d e0 68 a8 1b 8d e0 68 52 2b 8d e0
e8 91 be 85 df <0f> 0b 7f 01 42 2b 8d e0 83 c4 14 8b 44 24 2c 89 44 24 0c c7 44 
Continuing in 1 seconds.   
 BUG: yum/2130, lock held at task exit time!
 [da5d1b9c] {inode_init_once}
.. held by:               yum: 2130 [dfa8d9b0, 115]
... acquired at:               do_lookup+0x78/0x14d


Version-Release number of selected component (if applicable):
currently using 2.6.15-1.2032, but I've also seen the bug up to 2.6.17-1.2462. 
Haven't tried the newest devel kernel


How reproducible:  Everytime I try to update system using yum


Steps to Reproduce:
1. yum --exclude=kernel* --exclude=autofs* update
2. say 'yes' to all packages 
3. wait for error to occur after it's done downloading packages and doing the
transaction check
  
Actual results:


Expected results:


Additional info: I've manually updated to the newest version of yum in
core-development. 2.9.4-1
Comment 1 Will Woods 2006-08-18 11:11:19 EDT

*** This bug has been marked as a duplicate of 202648 ***

Note You need to log in before you can comment on or make changes to this bug.