Bug 202672 - xenguest-install.py traceback in libvirt.py
xenguest-install.py traceback in libvirt.py
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 15:58 EDT by Brian Brock
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 08:51:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Brock 2006-08-15 15:58:41 EDT
xenguest-install.py fails, with a traceback

run as:  
xenguest-install.py -n guest -f /xen/domains/guest.img -s 10 -r 300 -p -l
nfs:<server>:<path>/released/FC-5/GOLD/i386/os

2.6.17-1.2566.fc6xen
xen-3.0.2-23
yum updated to rawhide-20060815

output from xenguest-install.py:
Starting install...
libvir: Xen Daemon error : POST operation failed: No such domain guest
Failed to get devices for domain guest
Traceback (most recent call last):
  File "/usr/sbin/xenguest-install.py", line 476, in ?
    main()
  File "/usr/sbin/xenguest-install.py", line 467, in main
    start_paravirt_install(name, ram, disk, mac, uuid, bridge, src, options.extra)
  File "/usr/sbin/xenguest-install.py", line 344, in start_paravirt_install
    dom = conn.createLinux(cfgxml, 0)
  File "/usr/lib/python2.4/site-packages/libvirt.py", line 233, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed')
libvirt.libvirtError: virDomainCreateLinux() failed

xm dmesg tail after attempted install:
(XEN) Scrubbing Free RAM: ...........done.
(XEN) Xen trace buffers: disabled
(XEN) Xen is relinquishing VGA console.
(XEN) *** Serial input -> DOM0 (type 'CTRL-a' three times to switch input to Xen).
(XEN) (file=io_apic.c, line=2061) 
(XEN) ioapic_guest_write: apic=0, pin=4, old_irq=4, new_irq=4
(XEN) ioapic_guest_write: old_entry=000009f1, new_entry=000109f1
(XEN) ioapic_guest_write: Attempt to modify IO-APIC pin for in-use IRQ!
(XEN) (file=irq.c, line=464) Cannot bind IRQ 4 to guest. In use by 'ns16550'.
(XEN) (file=irq.c, line=464) Cannot bind IRQ 2 to guest. In use by 'cascade'.
(XEN) (file=irq.c, line=464) Cannot bind IRQ 4 to guest. In use by 'ns16550'.
(XEN) (file=irq.c, line=464) Cannot bind IRQ 2 to guest. In use by 'cascade'.
(XEN) (file=dom0_ops.c, line=396) Domain 0 says that IO-APIC REGSEL is good

doesn't quite look like a dup of similar bugs
Comment 1 Jeremy Katz 2006-08-16 08:51:32 EDT
FC5 i386 PV isn't compatible with current i386 due to the PAE switch.  You'll
see a (slightly) better error in /var/log/xend-debug.log

Note You need to log in before you can comment on or make changes to this bug.