Bug 202723 - SMP kernels with versions 2.6.17 do not resume from suspend
SMP kernels with versions 2.6.17 do not resume from suspend
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 19:24 EDT by Paul Johnson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-09 20:05:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Johnson 2006-08-15 19:24:41 EDT
Description of problem: kernel-smp with versions 2.6.17 do not resume from
suspend.  This is a Dell Latitude D820 laptop with SATA hard disk.  I do not
have suspend trouble with kernels in the 2.6.16 series.  In particular, this one
DOES work fine: kernel-smp-2.6.16-1.2133_FC5 

Version-Release number of selected component (if applicable):


kernel-smp-2.6.17-1.2157_FC5
kernel-smp-2.6.17-1.2174_FC5

How reproducible:

Suspend to RAM with Gnome-Power-Manager.  Resume fails.  With earlier versions
of the 2.6.17 kernels, the system resumed, but the screen stayed dark. It was
possible to log in from the network and reboot.  With the last two versions
listed above, the result is a system lockup.  There is no evidence that the file
system is re-mounted at all.

Steps to Reproduce:
1. suspend to ram
2. when light slowly flashes close lid
3. open lid
  
Actual results:

System lock up.  At 17:15:07, I suspended.  Upon re-opening lid, the lockup
occurred, and I powered down with the button. I did not turn the machine back on
until 17:55:05. Note there are no log messages between the two events. From
/var/log/messages


Aug 15 17:15:07 pols125 gnome-power-manager: (pauljohn) Suspending computer
because user clicked suspend from tray menu
Aug 15 17:55:05 pols125 syslogd 1.4.1: restart.
Aug 15 17:55:06 pols125 kernel: klogd 1.4.1, log source = /proc/kmsg started.
Aug 15 17:55:06 pols125 kernel: Linux version 2.6.16-1.2133_FC5smp
(brewbuilder@hs20-bc2-2.build.redhat.com) (gcc version 4.1.1 20060525 (Red Hat
4.1.1-1)) #1 SMP Tue Jun 6 01:52:09 EDT 2006
Aug 15 17:55:06 pols125 kernel: BIOS-provided physical RAM map:
Aug 15 17:55:06 pols125 kernel:  BIOS-e820: 0000000000000000 - 000000000009f000
(usable)
Aug 15 17:55:06 pols125 kernel:  BIOS-e820: 000000000009f000 - 00000000000a0000
(reserved)
Aug 15 17:55:06 pols125 kernel:  BIOS-e820: 0000000000100000 - 000000003fe91400
(usable)
Aug 15 17:55:06 pols125 kernel:  BIOS-e820: 000000003fe91400 - 0000000040000000
(reserved)
Aug 15 17:55:06 pols125 kernel:  BIOS-e820: 00000000e0000000 - 00000000f0007000
(reserved)
Aug 15 17:55:06 pols125 kernel:  BIOS-e820: 00000000f0008000 - 00000000f000c000
(reserved)
Aug 15 17:55:06 pols125 kernel:  BIOS-e820: 00000000fec00000 - 00000000fec10000
(reserved)
Aug 15 17:55:06 pols125 kernel:  BIOS-e820: 00000000fed20000 - 00000000feda0000
(reserved)
Aug 15 17:55:06 pols125 kernel:  BIOS-e820: 00000000fee00000 - 00000000fee10000
(reserved)
Aug 15 17:55:06 pols125 kernel:  BIOS-e820: 00000000ffb00000 - 0000000100000000
(reserved)



Expected results:

restart.

Additional info:

Tell me what other info will help, I will provide
Comment 1 Paul Johnson 2006-10-09 20:05:00 EDT
I upgraded from FC5 updates-testing  to kernel-smp-2.6.18-1.2189.fc5 and now the
Dell Inspiron D820 does suspend and resume, wireless & nvidia commercial driver
work fine without any special fussing.

Note You need to log in before you can comment on or make changes to this bug.