Bug 202740 - yum headers much too large
yum headers much too large
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-16 02:42 EDT by Nils Philippsen
Modified: 2014-01-21 17:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 14:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2006-08-16 02:42:32 EDT
Description of problem:

When updating/upgrading, yum downloads headers that are nearly as large as the
final RPM itself.

Version-Release number of selected component (if applicable):

yum-2.6.1-0.fc5

How reproducible:

Easy

Steps to Reproduce:
1. yum upgrade
  
Actual results:

root@wombat:/var/cache/yum/updates/packages> ls -l
squirrelmail-1.4.8-1.fc5.noarch.rpm  ../headers/squirrelmail-1.4.8-1.fc5.noarch.hdr
-rw-r--r-- 1 root root 4502093 Aug 15 18:39
../headers/squirrelmail-1.4.8-1.fc5.noarch.hdr
-rw-r--r-- 1 root root 4502533 Aug 15 18:39 squirrelmail-1.4.8-1.fc5.noarch.rpm

Expected results:

yum headers significantly smaller than RPM (I don't think squirrelmail has only
440 bytes of payload).

Additional info:

I've seen this for quite a while, interesting is that there are no headers in
the repositories I looked at, so I guess it makes partial downloads of the
packages (and miscalculates severely).
Comment 1 Seth Vidal 2006-08-19 15:21:36 EDT
this feels much more like a proxy problem to me. Something not allowing
byte-ranges and doing something broken with it.

Is there anything like that in place?
Comment 2 Nils Philippsen 2006-08-22 10:39:48 EDT
Seems to be so (but the machines I see this on use proxies I can't fiddle
with)... Would it be possible for yum to use these files as packages if it
already had to download them completely?
Comment 3 Nils Philippsen 2006-08-29 04:43:27 EDT
I saw something else, namely that some headers are in the few KB range and
others in the MB range. I guess that some mirrors don't allow partial downloads.
Reusing the (already downloaded) package file would be a big imporvement in that
situation.
Comment 4 Jeremy Katz 2007-04-25 14:17:59 EDT
With yum 3.1.x and beyond, we're just killing off the header downloads entirely.

Note You need to log in before you can comment on or make changes to this bug.