Bug 202758 - Standard legacy software packages should be installed by default
Standard legacy software packages should be installed by default
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-08-16 06:48 EDT by Kerry Kobashi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-16 11:01:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kerry Kobashi 2006-08-16 06:48:30 EDT
Description of problem: 
Standard legacy software packages not being installed are causing problems in 
upgrading Firefox. 
Version-Release number of selected component (if applicable): 
How reproducible: 
On Firefox releases over, the standard c++ library is needed to launch 
Steps to Reproduce: 
1. download new version of firefox 
2. run it 
3. error comes up about stdc++ missing 
Actual results: 
Expected results: 
firefox should run 
Additional info: 
This problem exists because the checkboxes in the installation process does 
not consider to turn on the software legacy packages by default. Consider that 
Firefox is the default browser in Fedora and is launched from the task bar so 
better integration is needed in event that things don't work. 
Presently Firefox appears to have a problem in updating. I have tried on 
Fedora Core 5 updating Firefox from to but the updater does 
not work. This results in users having to download Firefox tarball and 
installing it. Since Fedora Core doesn't have software legacy turned on, users 
will only get frustrated having the files missing and are forced to go yum for 
it. This problem can be solved simply by turning on those checkboxes to avoid 
this  mistake. This is a high profile problem that has not been resolved by 
the Firefox team and is noted in their zine: 
Comment 1 Jeremy Katz 2006-08-16 11:01:55 EDT
If you're installing software which is packaged properly, then the requirements
will pull in the compatibility bits.  By default, Fedora is forward looking and
so compatability support for older releases is not installed without the user
asking for it.

Note You need to log in before you can comment on or make changes to this bug.