Bug 20278 - Only add the first lvs to cluster when pulse run as daemon
Summary: Only add the first lvs to cluster when pulse run as daemon
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: piranha (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: Wil Harris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-03 13:56 UTC by Guillermo Ricardo Capelli
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-08 19:45:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Red Hat Bugzilla 2000-11-03 13:56:32 UTC
I had the following configuration file ( lvs.cf )

primary = 192.168.2.4
service = lvs
rsh_command = rsh
backup_active = 0
backup = 0.0.0.0
heartbeat = 1
heartbeat_port = 539
keepalive = 6
deadtime = 18
network = nat
nat_router = 192.168.1.5 eth0:0
virtual UnoVirtual {
     active = 1
     address = 192.168.2.5 eth1:0 
     port = 8900
     persistent = 300
     send = "GET / HTTP/1.0\r\n\r\n"
     expect = "HTTP"
     load_monitor = rup
     scheduler = rr
     protocol = tcp
     persistent = 300
     timeout = 6
     reentry = 15
     server real8900 {
         address = 192.168.1.45
         active = 1
         weight = 1
     }
}
virtual DosVirtual {
     active = 1
     address = 192.168.2.5 eth1:1
     port = 80
     persistent = 300
     send = "GET / HTTP/1.0\r\n\r\n"
     expect = "HTTP"
     load_monitor = rup
     scheduler = rr
     protocol = tcp
     persistent = 300
     timeout = 6
     reentry = 15
     server Real80 {
         address = 192.168.1.50
         active = 1
         weight = 1
     }
     server Linux1 {
         address = 192.168.1.1
         active = 1
         weight = 1
     }
}

when i run the pulse as daemon only add a first virtual server bu if
I run pulse -n all virtual server are added, why.

Comment 1 Red Hat Bugzilla 2000-11-03 16:20:42 UTC
It looks like you are mapping the same ip address to two different interfaces
(eth1:0 and eth1:1). You cannot do that. It's like trying to define two ethernet
cards with the same IP address - there's no routing logic that can be applied.

You etiher need to make them two different addresses, or specify the same
interface.



Comment 2 Red Hat Bugzilla 2000-11-03 16:22:47 UTC
Followup....

I not this does not explain the difference in behavior. I'll have to try that
and see why.

Comment 3 Red Hat Bugzilla 2000-11-20 16:43:50 UTC
Any progress?


Comment 4 Red Hat Bugzilla 2000-11-20 16:55:02 UTC
Another note...

We are about to release a new piranha (today hopefully) that has patches which
may affect this problem. Please keep a watch on
ftp://people.redhat.com/kbarrett/HA/experimental/ and let me know if this makes
any difference.



Comment 5 Red Hat Bugzilla 2001-01-08 19:44:59 UTC
Is this still a problem with the current release on the ftp site?


Comment 6 Red Hat Bugzilla 2001-01-16 17:12:53 UTC
Status changed until customer verifies that this is still a problem with current
release.



Note You need to log in before you can comment on or make changes to this bug.