Bug 202794 - dns server search order not followed without restart of bind
dns server search order not followed without restart of bind
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-16 10:57 EDT by Thomas J. Baker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 08:36:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2006-08-16 10:57:05 EDT
There is some named/NetworkManager interaction problem with the result being
that dns queries don't go to servers in the order my dhcpd server specifies. The
first server listed is a local dns server for my internal network, which seems
to be being ignored. I think this happened with a post fc6t2 update since I
think this worked initially. Restarting bind fixes the problem for a few moments
but then dns queries start failing again. selinux is permissive.


Version-Release number of selected component (if applicable):

NetworkManager-0.7.0-0.cvs20060529.5
bind-9.3.2-36.fc6
Comment 1 Thomas J. Baker 2006-08-30 11:11:14 EDT
NetworkManager-0.7.0-0.cvs20060529.6 has not fixed this problem. It is possible
that any DNS server I specify via dhcp is being ignored after a time and just
root servers are being queried. What information could I provide that would aid
in debugging this issue?
Comment 2 Johan Kok 2006-09-20 06:45:38 EDT
Can you supply the contents of /etc/resolv.conf? Could you also take a look at
bug #205783 ? I'm not completly sure, but it looks like a duplicate.
Comment 3 Thomas J. Baker 2006-09-20 08:21:42 EDT
This was fixed with the reversion to 0.6.x version of NetworkManager. I have not
seen the problem since then.
Comment 4 Matthias Clasen 2006-09-20 08:36:01 EDT
Thanks for letting us know. I'll close this bug then.

Note You need to log in before you can comment on or make changes to this bug.