Bug 202807 - e2fsprogs has overflows at 16T
e2fsprogs has overflows at 16T
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks: 202799 207719
  Show dependency treegraph
 
Reported: 2006-08-16 11:31 EDT by Eric Sandeen
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 04:12:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2006-08-16 11:31:44 EDT
e2fsprogs has arithmetic overflows when attempting to mkfs, fsck, resize, etc a
filesystem with 2^32-1 blocks.

I've got patches that I will be sending upstream to address this issue, but
wanted to get it logged against FC6 now.  Patches should be available soon; the
ext3 devels seem to be interested in sorting this issue out before moving on to
48 bits in ext4.

(Blocks 202799 because kernel fixes can't be tested without userspace which can
create such a large filesystem.)
Comment 1 Thomas Woerner 2006-10-02 04:12:55 EDT
This has been fixed in package e2fsprogs-1.39-7 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.