Bug 202850 - right-click -> Edit Menus throws an error
right-click -> Edit Menus throws an error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-16 15:27 EDT by Bill Nottingham
Modified: 2014-03-16 23:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 18:30:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the error dialog (46.23 KB, image/png)
2006-08-16 15:27 EDT, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2006-08-16 15:27:08 EDT
Description of problem:

If I right-click -> Edit Menus on the fedora icon, I get the
attached error dialog.

This is wrong in a few ways:
1) what's with that GTK_RC_FILES stuff?
2) it actually *did* launch it

Version-Release number of selected component (if applicable):

gnome-panel-2.15.91-2.fc6
Comment 1 Bill Nottingham 2006-08-16 15:27:08 EDT
Created attachment 134336 [details]
the error dialog
Comment 2 Bill Nottingham 2006-08-16 15:29:14 EDT
Also, the panel crashes a *lot* when running g-simple-menu-editor.
Comment 3 Bill Nottingham 2006-08-16 15:31:00 EDT
So, this time, the error dialog said:

Could not execute 'gmenu-simple-editor'
/usr/share/locale/en.UTF-8/LC_MESSAGES/gnome-vfs-2.0.mo

Is it using freed memory?
Comment 4 Bill Nottingham 2006-08-16 15:34:46 EDT
Memory status: size: 53035008 vsize: 0 resident: 53035008 share: 0 rss: 16855040
rss_rlim: 0
CPU usage: start_time: 1155757350 rtime: 0 utime: 49 stime: 0 cutime:28 cstime:
0 timeout: 21 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/gnome-panel'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208993216 (LWP 4078)]
0xb7f27402 in __kernel_vsyscall ()
#0  0xb7f27402 in __kernel_vsyscall ()
#1  0x001bc983 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x00475d66 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x00fd2600 in __find_specmb () from /lib/libc.so.6
#5  0x00fb971f in vfprintf () from /lib/libc.so.6
#6  0x00fdb3fc in vasprintf () from /lib/libc.so.6
#7  0x0050c3d7 in g_vasprintf () from /lib/libglib-2.0.so.0
#8  0x004fe4a6 in g_strdup_vprintf () from /lib/libglib-2.0.so.0
#9  0x008f6889 in gtk_message_dialog_format_secondary_text ()
   from /usr/lib/libgtk-x11-2.0.so.0
#10 0x08074a63 in panel_error_dialog (parent=0x0, screen=0x9fbc0f8, 
    class=0x80b00ec "cannot_exec_gmenu-simple-editor", auto_destroy=1, 
    primary_text=0xa148ba0 "Could not execute 'gmenu-simple-editor'", 
    secondary_text=0x10 <Address 0x10 out of bounds>) at panel-util.c:332
#11 0x08089a01 in panel_menu_button_invoke_menu (button=0xa112830, 
    callback_name=0xa1124a0 "edit") at panel-menu-button.c:1018
#12 0x00672139 in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
#13 0x00664f0b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#14 0x00675d63 in g_signal_override_class_closure ()
   from /lib/libgobject-2.0.so.0
#15 0x0067725f in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#16 0x00677419 in g_signal_emit () from /lib/libgobject-2.0.so.0
#17 0x009fde94 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#18 0x008f3598 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#19 0x008f4b62 in gtk_menu_shell_append () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x008ec735 in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
#21 0x008e6890 in gtk_marshal_BOOLEAN__VOID ()
   from /usr/lib/libgtk-x11-2.0.so.0
#22 0x006636f9 in g_value_set_static_boxed () from /lib/libgobject-2.0.so.0
#23 0x00664f0b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#24 0x006763b3 in g_signal_override_class_closure ()
   from /lib/libgobject-2.0.so.0
#25 0x00677027 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#26 0x00677419 in g_signal_emit () from /lib/libgobject-2.0.so.0
#27 0x009f9ae8 in gtk_widget_get_default_style ()
   from /usr/lib/libgtk-x11-2.0.so.0
#28 0x008dfd33 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#29 0x008e0f37 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#30 0x003690fa in gdk_add_client_message_filter ()
   from /usr/lib/libgdk-x11-2.0.so.0
#31 0x004e3372 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#32 0x004e634f in g_main_context_check () from /lib/libglib-2.0.so.0
#33 0x004e66f9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#34 0x008e13b4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#35 0x0805fadc in main (argc=7, argv=0xbfc3fd64) at main.c:97

Thread 1 (Thread -1208993216 (LWP 4078)):
#0  0xb7f27402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x001bc983 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x00475d66 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x00fd2600 in __find_specmb () from /lib/libc.so.6
No symbol table info available.
#5  0x00fb971f in vfprintf () from /lib/libc.so.6
No symbol table info available.
#6  0x00fdb3fc in vasprintf () from /lib/libc.so.6
No symbol table info available.
#7  0x0050c3d7 in g_vasprintf () from /lib/libglib-2.0.so.0
No symbol table info available.
#8  0x004fe4a6 in g_strdup_vprintf () from /lib/libglib-2.0.so.0
No symbol table info available.
#9  0x008f6889 in gtk_message_dialog_format_secondary_text ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#10 0x08074a63 in panel_error_dialog (parent=0x0, screen=0x9fbc0f8, 
    class=0x80b00ec "cannot_exec_gmenu-simple-editor", auto_destroy=1, 
    primary_text=0xa148ba0 "Could not execute 'gmenu-simple-editor'", 
    secondary_text=0x10 <Address 0x10 out of bounds>) at panel-util.c:332
	dialog = (GtkWidget *) 0xa14a800
	freeme = 0x0
#11 0x08089a01 in panel_menu_button_invoke_menu (button=0xa112830, 
    callback_name=0xa1124a0 "edit") at panel-menu-button.c:1018
	error = (GError *) 0xa145720
	screen = (GdkScreen *) 0x9fbc0f8
	__PRETTY_FUNCTION__ = "panel_menu_button_invoke_menu"
#12 0x00672139 in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
No symbol table info available.
#13 0x00664f0b in g_closure_invoke () from /lib/libgobject-2.0.so.0
No symbol table info available.
#14 0x00675d63 in g_signal_override_class_closure ()
   from /lib/libgobject-2.0.so.0
No symbol table info available.
#15 0x0067725f in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
No symbol table info available.
#16 0x00677419 in g_signal_emit () from /lib/libgobject-2.0.so.0
No symbol table info available.
#17 0x009fde94 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#18 0x008f3598 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#19 0x008f4b62 in gtk_menu_shell_append () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#20 0x008ec735 in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#21 0x008e6890 in gtk_marshal_BOOLEAN__VOID ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#22 0x006636f9 in g_value_set_static_boxed () from /lib/libgobject-2.0.so.0
No symbol table info available.
#23 0x00664f0b in g_closure_invoke () from /lib/libgobject-2.0.so.0
No symbol table info available.
#24 0x006763b3 in g_signal_override_class_closure ()
   from /lib/libgobject-2.0.so.0
No symbol table info available.
#25 0x00677027 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
No symbol table info available.
#26 0x00677419 in g_signal_emit () from /lib/libgobject-2.0.so.0
No symbol table info available.
#27 0x009f9ae8 in gtk_widget_get_default_style ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#28 0x008dfd33 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#29 0x008e0f37 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#30 0x003690fa in gdk_add_client_message_filter ()
   from /usr/lib/libgdk-x11-2.0.so.0
No symbol table info available.
#31 0x004e3372 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#32 0x004e634f in g_main_context_check () from /lib/libglib-2.0.so.0
No symbol table info available.
#33 0x004e66f9 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#34 0x008e13b4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#35 0x0805fadc in main (argc=7, argv=0xbfc3fd64) at main.c:97
	context = <value optimized out>
	program = (GnomeProgram *) 0x9fa3428
#0  0xb7f27402 in __kernel_vsyscall ()
Comment 5 Matthias Clasen 2006-08-16 18:16:13 EDT
Seems to be using the beginning of the environment; missing NULL termination to
some varargs call ?
Comment 6 Ray Strode [halfline] 2006-08-16 18:30:37 EDT
I think this should be fixed...reopen if no.

Note You need to log in before you can comment on or make changes to this bug.