Bug 202881 - AVC denied messages for semodule/netfilter_contexts.tmp
Summary: AVC denied messages for semodule/netfilter_contexts.tmp
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-16 21:41 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-21 18:05:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2006-08-16 21:41:51 UTC
Description of problem:
type=AVC msg=audit(1155764392.635:42019): avc:  denied  { write } for  pid=27664 
comm="semodule" name="contexts" dev=cciss/c0d0p2 ino=1082871 scontext=user_u:
system_r:semanage_t:s0 tcontext=system_u:object_r:default_context_t:s0 
tclass=dir
type=AVC msg=audit(1155764392.635:42019): avc:  denied  { add_name } for  
pid=27664 comm="semodule" name="netfilter_contexts.tmp" scontext=user_u:
system_r:semanage_t:s0 tcontext=system_u:object_r:default_context_t:s0 
tclass=dir
type=AVC msg=audit(1155764392.635:42019): avc:  denied  { create } for  
pid=27664 comm="semodule" name="netfilter_contexts.tmp" scontext=user_u:
system_r:semanage_t:s0 tcontext=user_u:object_r:default_context_t:s0 tclass=file
type=AVC msg=audit(1155764392.635:42020): avc:  denied  { write } for  pid=27664 
comm="semodule" name="netfilter_contexts.tmp" dev=cciss/c0d0p2 ino=1081448 
scontext=user_u:system_r:semanage_t:s0 tcontext=user_u:object_r:
default_context_t:s0 tclass=file
type=AVC msg=audit(1155764392.635:42021): avc:  denied  { remove_name } for  
pid=27664 comm="semodule" name="netfilter_contexts.tmp" dev=cciss/c0d0p2 
ino=1081448 scontext=user_u:system_r:semanage_t:s0 tcontext=system_u:object_r:
default_context_t:s0 tclass=dir
type=AVC msg=audit(1155764392.635:42021): avc:  denied  { rename } for  
pid=27664 comm="semodule" name="netfilter_contexts.tmp" dev=cciss/c0d0p2 
ino=1081448 scontext=user_u:system_r:semanage_t:s0 tcontext=user_u:object_r:
default_context_t:s0 tclass=file

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.3.7-1

Expected results:
No AVC denied messages... ;-)

Comment 1 Daniel Walsh 2006-08-18 13:32:30 UTC
Could you try 

setenforce 0
semoudle -b /usr/share/selinux/targeted/base.pp
setenforce 1
semoudle -b /usr/share/selinux/targeted/base.pp

The second one should not generate avc messages.

Comment 2 Robert Scheck 2006-08-20 10:57:28 UTC
Guessing you mean semodule instead of semoudle? Yes, I'm currently running  the 
SELinux targeted policy in permissive but I can't switch to enforced yet without 
breaking other stuff on this system.

Comment 3 Daniel Walsh 2006-08-20 14:41:57 UTC
Ok, but does running the 
semodule -b /usr/share/selinux/targeted/base.pp still cause the avc messages?

What problems are you having that are preventing you running in enforcing mode?

Comment 4 Daniel Walsh 2006-08-21 18:05:00 UTC
I am closing this because I beleive this is a resolved bug.


Note You need to log in before you can comment on or make changes to this bug.