Bug 202886 - RFE: add info to pvs or pvdisplay about metadata space availible in each pv
Summary: RFE: add info to pvs or pvdisplay about metadata space availible in each pv
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 4.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Bryn M. Reeves
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
: 409071 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-16 21:54 UTC by Corey Marthaler
Modified: 2018-10-19 21:34 UTC (History)
4 users (show)

Fixed In Version: RHBA-2008-0776
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 20:07:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0776 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2008-07-23 17:19:45 UTC

Description Corey Marthaler 2006-08-16 21:54:41 UTC
Description of problem:
There's no easy way to tell how much (if any) metadata space is available on
each PV.

[root@taft-04 ~]# pvcreate /dev/sdb1 /dev/sdc1 /dev/sdd1
  Physical volume "/dev/sdb1" successfully created
  Physical volume "/dev/sdc1" successfully created
  Physical volume "/dev/sdd1" successfully created
[root@taft-04 ~]# pvcreate --metadatacopies 0 /dev/sdb2 /dev/sdc2 /dev/sdd2
  Physical volume "/dev/sdb2" successfully created
  Physical volume "/dev/sdc2" successfully created
  Physical volume "/dev/sdd2" successfully created

[root@taft-04 ~]# pvscan
  PV /dev/sdb1         lvm2 [136.23 GB]
  PV /dev/sdb2         lvm2 [136.23 GB]
  PV /dev/sdc1         lvm2 [136.23 GB]
  PV /dev/sdc2         lvm2 [136.23 GB]
  PV /dev/sdd1         lvm2 [930.89 GB]
  PV /dev/sdd2         lvm2 [930.89 GB]
  Total: 6 [2.35 TB] / in use: 0 [0   ] / in no VG: 6 [2.35 TB]
[root@taft-04 ~]# pvs
  PV         VG   Fmt  Attr PSize   PFree
  /dev/sdb1       lvm2 --   136.23G 136.23G
  /dev/sdb2       lvm2 --   136.23G 136.23G
  /dev/sdc1       lvm2 --   136.23G 136.23G
  /dev/sdc2       lvm2 --   136.23G 136.23G
  /dev/sdd1       lvm2 --   930.89G 930.89G
  /dev/sdd2       lvm2 --   930.89G 930.89G



Version-Release number of selected component (if applicable):
[root@taft-04 ~]# rpm -q lvm2
lvm2-2.02.06-6.0.RHEL4

Comment 1 Milan Broz 2007-08-03 10:05:43 UTC
2.02.27 has "pvs -o +mda_count"

*** This bug has been marked as a duplicate of 247444 ***

Comment 2 Bryn M. Reeves 2007-08-03 10:34:58 UTC
I read this one as slightly different to bug 247444 - it's asking about viewing
how much space is remaining in the metadata areas, rather than how many MDAs
exist and where they are.

I guess that's easy enough to add to pvs etc. too though.


Comment 3 Milan Broz 2007-08-03 10:39:09 UTC
Ah, ok, so if mda_count is not enough, please reopen this.

Comment 4 Bryn M. Reeves 2007-11-05 10:46:30 UTC
As discussed on IRC this one's asking for the amount of free space left in the
MDAs. Should be addressed along with the other metadata handling improvements.


Comment 6 Bryn M. Reeves 2007-12-03 19:58:02 UTC
*** Bug 409071 has been marked as a duplicate of this bug. ***

Comment 7 Alasdair Kergon 2008-02-28 23:19:38 UTC
So this one got in upstream?  Let's set to POST then so we don't forget.

Comment 8 Alasdair Kergon 2008-02-28 23:21:35 UTC
and mention *which* upstream version it got into: 2.02.29 from the WHATS_NEW
diff above

Comment 11 Corey Marthaler 2008-06-09 19:09:52 UTC
Verified in lvm2-2.02.36-1.el4.

Comment 13 errata-xmlrpc 2008-07-24 20:07:10 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0776.html


Note You need to log in before you can comment on or make changes to this bug.