Bug 202928 - Multihome patch does not support IPv6
Summary: Multihome patch does not support IPv6
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ftp   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-17 10:30 UTC by Peter Bieringer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: ftp-0.17-33.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-18 10:37:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Bieringer 2006-08-17 10:30:44 UTC
FC5 contains also buggy version ftp-0.17-32.1.2.fc5
Could the working version from devel (ftp-0.17-32.1.2.4) be pushed to FC5 please?

+++ This bug was initially created as a clone of Bug #199145 +++

Description of problem:

The IPv6 is not correctly supported on multihome machines because of ftp
multihome patch is not IPv6 compliant.

Version-Release number of selected component (if applicable):
0.17-32.1.2.1

How reproducible:
Always.

Steps to Reproduce:
1. Connect to ftp server using IPv6 protocol from multihome host
2. Login
3. Execute command 'dir'
  
Actual results:
$ /usr/bin/ftp ipv6srot6.ipv6.redhat.usu
Connected to ipv6srot6.ipv6.redhat.usu (fec0::f101:210:5aff:fed5:7e33).
220 (vsFTPd 2.0.4)
Name (ipv6srot6.ipv6.redhat.usu:lsmid): anonymous
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> dir
use of scoped address can be troublesome
ftp multihome bind: Invalid argument
ftp>

Expected results:
The content of the directory

Additional info:
N/A

-- Additional comment from pvrabec@redhat.com on 2006-07-28 10:52 EST --
Created an attachment (id=133239)
fix

Comment 1 Marcela Mašláňová 2006-08-17 12:12:18 UTC
Thanks for info. 
Patch added to update - testing.


Note You need to log in before you can comment on or make changes to this bug.