Bug 202934 - smb_retry errors when trying to mount from linux to a windows 2000 share
smb_retry errors when trying to mount from linux to a windows 2000 share
Status: CLOSED DUPLICATE of bug 168280
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
4.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-17 07:41 EDT by Peter Odufona
Modified: 2007-11-16 20:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-09 10:04:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Odufona 2006-08-17 07:41:51 EDT
Description of problem:

Kernel: 2.6.9-22.ELsmp

Using samba-client-3.0.10-1.4E.2 & samba-client-3.0.10-1.4E.6, I get a 30 second
delay when attaching (mount -t smbfs) a windows share to my linux box.

I get the following associated errors: -

smb_retry: no connection process
smb_add_request: request [xxxxxxxx, mid=0] timed out!
smb_delete_inode: could not close inode 2

xxxxxxxx means hexa numbers, like dead9b80, db7a2e80 etc.

Version-Release number of selected component (if applicable):

samba-3.0.10-1.4E.2
samba-common-3.0.10-1.4E.2
samba-client-3.0.10-1.4E.2

Then pulled the following off our satellite server:

samba-3.0.10-1.4E.6
samba-common-3.0.10-1.4E.6
samba-client-3.0.10-1.4E.6

But still same issue!

How reproducible:


Steps to Reproduce:
  
1. create a share called 'reports' on a win2K client & give 'everyone' full
access security & permission rights to the share.
2. on the linux box create a directory under /mnt called reports with rwx for all.
3. still on the linux box type: mount -t smbfs //client/reports /mnt/reports -o
username=username,password=password 
  
Actual results:

smb_retry: no connection process

then after about 30-40 seconds later get error:

smb_add_request: request [f2f91e80, mid=0] timed out!
smb_retry: no connection process
smb_delete_inode: could not close inode 2

 
Expected results:

windows share to mount under /mnt/reports

Additional info:

Please checkout the following URLs:

http://bugs.centos.org/view.php?id=1062
http://www.usenetlinux.com/archive/topic.php/t-466198.html

I have pulled down the latest stable release from samba.org which is a tar ball
and I am in the process of testing to see if this resolves the issue.

would prefer an rpm though as cleaner and all aspects of samba i.e. samba,
samba-client & samba-common can be updated properly.
Comment 1 Greg Swallow 2006-09-22 17:38:47 EDT
This looks to me to be a duplicate of:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=168280
Comment 2 Jeff Layton 2007-05-09 10:04:50 EDT

*** This bug has been marked as a duplicate of 168280 ***

Note You need to log in before you can comment on or make changes to this bug.