Bug 202944 - Library dependancies
Library dependancies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdemultimedia (Show other bugs)
6
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-17 08:51 EDT by Alan Cox
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-06 10:19:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2006-08-17 08:51:32 EDT
Trying to remove kdemultimedia-devel.i386 I was suprised to get errors about
libraries required by other apps. Have the libs or some of them somehow ended up
in the wrong package or did I just mis-understand what yum was moaning about ?
Comment 1 Kevin Fenzi 2006-09-05 13:12:20 EDT
I am seeing this as well with current devel/rawhide. 

kdemultimedia apparently is requiring kdemultimedia-devel, which also happens 
to install 28 other -devel packages here. 

It looks like at least some and possibly all of the .so's in kdemultimedia-
devel are in the wrong package, and should be in the main package instead of 
devel. 

rpm -e kdemultimedia-devel
error: Failed dependencies:
        libnoatunarts.so is needed by (installed) kdemultimedia-3.5.4-1.fc6.i386
        libwinskinvis.so is needed by (installed) kdemultimedia-3.5.4-1.fc6.i386
Comment 2 Ngo Than 2006-09-06 10:19:08 EDT
it's now fixed in kdemultimedia-3_5_4-2_fc6. Thanks for your report

Note You need to log in before you can comment on or make changes to this bug.